summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-02-26 22:35:29 +0100
committerhaawda2018-02-26 22:35:29 +0100
commit1f193cd5aab75f7327e19089b9a5a16e288e7711 (patch)
treef78bc019ec5c280219e2ae96897afef9e46f62b5
downloadaur-1f193cd5aab75f7327e19089b9a5a16e288e7711.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e28ab863f412
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gri-git
+ pkgdesc = A script-based language for scientific graphics programming
+ pkgver = 2.12.22.85.g7ecf421
+ pkgrel = 1
+ url = http://gri.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = ghostscript
+ makedepends = imagemagick6
+ makedepends = texlive-core
+ makedepends = perl-perl4-corelibs
+ options = !makeflags
+ source = git+https://github.com/dankelley/gri.git
+ sha256sums = SKIP
+
+pkgname = gri-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..236913d6b979
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+# Contributor: big_gie nbigaouette . at . gmail.com
+
+pkgname=gri-git
+pkgver=2.12.22.85.g7ecf421
+pkgrel=1
+pkgdesc="A script-based language for scientific graphics programming"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://gri.sourceforge.net/"
+makedepends=('ghostscript' 'imagemagick6' 'texlive-core' 'perl-perl4-corelibs')
+source=("git+https://github.com/dankelley/gri.git")
+sha256sums=('SKIP')
+options=('!makeflags')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --tags | tr - .
+}
+
+build() {
+ cd ${pkgname%-git}
+ aclocal
+ autoconf
+ automake --add-missing
+ CXXFLAGS+=" -fpermissive" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+ make DESTDIR=$pkgdir install
+}