summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:41:50 +0200
committergraziano.giuliani2015-07-04 16:41:50 +0200
commitdde716543ddf3e757364846f9acdce831b3f7501 (patch)
treee214c67eed093e4cd18ea4891ba312b6efdfa3ce
downloadaur-dde716543ddf3e757364846f9acdce831b3f7501.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO15
-rw-r--r--NWS_license.txt55
-rw-r--r--PKGBUILD25
4 files changed, 110 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..0069ae2a5441
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = grib2ctl
+ pkgdesc = Takes GRIB files and makes GrADS control files
+ pkgver = 0.9.13
+ pkgrel = 1
+ url = http://www.cpc.ncep.noaa.gov/products/wesley/grib2ctl.html
+ arch = any
+ license = custom:NWS
+ depends = perl
+ source = ftp://ftp.cpc.ncep.noaa.gov/wd51we/wgrib.scripts/grib2ctl.pl
+ source = NWS_license.txt
+ md5sums = 56c14e322311d48ebaa67e32a991a883
+ md5sums = 64f9f7f5ad383df409986d8a67d2fa78
+
+pkgname = grib2ctl
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0069ae2a5441
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = grib2ctl
+ pkgdesc = Takes GRIB files and makes GrADS control files
+ pkgver = 0.9.13
+ pkgrel = 1
+ url = http://www.cpc.ncep.noaa.gov/products/wesley/grib2ctl.html
+ arch = any
+ license = custom:NWS
+ depends = perl
+ source = ftp://ftp.cpc.ncep.noaa.gov/wd51we/wgrib.scripts/grib2ctl.pl
+ source = NWS_license.txt
+ md5sums = 56c14e322311d48ebaa67e32a991a883
+ md5sums = 64f9f7f5ad383df409986d8a67d2fa78
+
+pkgname = grib2ctl
+
diff --git a/NWS_license.txt b/NWS_license.txt
new file mode 100644
index 000000000000..7c30166a5a22
--- /dev/null
+++ b/NWS_license.txt
@@ -0,0 +1,55 @@
+http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2
+
+NCEP codes for decoding and encoding data in GRIB2 format
+
+Note: These codes are provided as is for the use of NCEP data users. NCEP does
+not and can not provide any support for them.
+
+http://www.weather.gov/disclaimer
+
+Disclaimer
+ National Weather Service
+ National Headquarters
+[...]
+
+Use of Data and Products
+
+ The information on National Weather Service (NWS) Web pages are in the public
+ domain, unless specifically noted otherwise, and may be used without charge
+ for any lawful purpose so long as you do not: 1) claim it is your own (e.g.,
+ by claiming copyright for NWS information -- see below), 2) use it in a
+ manner that implies an endorsement or affiliation with NOAA/NWS, or 3)
+ modify its content and then present it as official government material. You
+ also cannot present information of your own in a way that makes it appear to
+ be official government information.
+
+ Use of the NWS name ("National Weather Service") and/or visual identifier
+ are protected under trademark law and may not be used without permission
+ from the NWS. Use of the NWS name and/ or visual identifier to identify
+ unaltered NWS content or links to NWS web sites are allowable uses.
+ Permission may be requested for this use at
+ http://www.weather.gov/logorequest. Permission is not required to display
+ unaltered NWS products which include the NWS name or NWS/NOAA visual
+ identifier as part of the original product. Neither the name nor visual
+ identifier may be used, however, in a manner that implies an endorsement or
+ affiliation with NOAA/NWS.
+
+ Before using information obtained from any NWS Web page special attention
+ should be given to the date and time of the data and products being
+ displayed.
+
+ The user assumes the entire risk related to its use of information on NWS
+ Web pages. NWS is provides such information "as is," and NWS disclaims any
+ and all warranties, whether express or implied, including (without
+ limitation) any implied warranties of merchantability or fitness for a
+ particular purpose. In no event will NWS be liable to you or to any third
+ party for any direct, indirect, incidental, consequential, special or
+ exemplary damages or lost profit resulting from any use or misuse of this
+ data.
+
+ As required by 17 U.S.C. ยง 403, third parties producing copyrighted works
+ consisting predominantly of the material appearing in NWS Web pages must
+ provide notice with such work(s) identifying the NWS material incorporated
+ and stating that such material is not subject to copyright protection.
+
+[...]
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a429a4379a36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Graziano Giuliani <giuliani@lamma.rete.toscana.it>
+
+pkgname=grib2ctl
+pkgver=0.9.13
+pkgrel=1
+pkgdesc="Takes GRIB files and makes GrADS control files"
+arch=('any')
+url="http://www.cpc.ncep.noaa.gov/products/wesley/grib2ctl.html"
+license=('custom:NWS')
+depends=('perl')
+source=(ftp://ftp.cpc.ncep.noaa.gov/wd51we/wgrib.scripts/${pkgname}.pl
+ NWS_license.txt)
+md5sums=('56c14e322311d48ebaa67e32a991a883'
+ '64f9f7f5ad383df409986d8a67d2fa78')
+
+build() {
+ echo "Nothing to build"
+}
+
+package() {
+ install -Dm755 ${srcdir}/${pkgname}.pl ${pkgdir}/usr/bin/${pkgname}
+ install -Dm755 ${srcdir}/NWS_license.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/NWS
+}