summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-08-07 09:25:57 +0200
committergraziano.giuliani2015-08-07 09:25:57 +0200
commita702b6e0880d356a078f76d7e41f8c80642c0e60 (patch)
tree8d5d80e7a3cc955d3fd272ec09b29fba14867868
parent92d751aba6a757f418ebbb9a8dc7b7c165e9e523 (diff)
downloadaur-a702b6e0880d356a078f76d7e41f8c80642c0e60.tar.gz
make aec opt-depend in build, make cmake needed for build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50755342ab23..14388ef5d638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grib_api
pkgdesc = A program interface for encoding and decoding GRIB messages
pkgver = 1.14.0
- pkgrel = 1
+ pkgrel = 2
url = https://software.ecmwf.int/wiki/display/GRIB/Home
arch = i686
arch = x86_64
@@ -10,12 +10,13 @@ pkgbase = grib_api
makedepends = gcc-fortran
makedepends = python2
makedepends = python2-numpy
+ makedepends = cmake
depends = openjpeg
depends = libpng
depends = python2
depends = netcdf
- optdepends = libaec
- optdepends = jasper
+ optdepends = libaec: for compression
+ optdepends = jasper: as an alternative to openjpeg
provides = grib_api
conflicts = grib_def
replaces = grib_api
diff --git a/PKGBUILD b/PKGBUILD
index 7fc03154d2a4..f84c5378c91d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=grib_api
pkgver=1.14.0
_attnum=3473437
-pkgrel=1
+pkgrel=2
pkgdesc="A program interface for encoding and decoding GRIB messages"
arch=('i686' 'x86_64')
url="https://software.ecmwf.int/wiki/display/GRIB/Home"
license=('LGPL3' 'GPL3')
depends=('openjpeg' 'libpng' 'python2' 'netcdf')
-optdepends=('libaec' 'jasper')
-makedepends=('gcc-fortran' 'python2' 'python2-numpy')
+optdepends=('libaec: for compression' 'jasper: as an alternative to openjpeg')
+makedepends=('gcc-fortran' 'python2' 'python2-numpy' 'cmake')
provides=('grib_api')
replaces=('grib_api' 'grib_def')
conflicts=('grib_def')
@@ -22,10 +22,11 @@ build() {
cd "$srcdir"/${pkgname}-${pkgver}-Source
mkdir -p build
cd build
+ [ -x /usr/bin/aec ] && has_aec=1 || has_aec=0
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=production \
-DCMAKE_INSTALL_DATAROOTDIR=/usr/share/$pkgname/definitions \
- -DCMAKE_INSTALL_DATADIR=/usr/share -DENABLE_AEC=1 -DENABLE_PNG=1 \
- -DENABLE_GRIB_THREADS=1 \
+ -DCMAKE_INSTALL_DATADIR=/usr/share -DENABLE_AEC=$has_aec \
+ -DENABLE_PNG=1 -DENABLE_GRIB_THREADS=1 \
-DOPENJPEG_INCLUDE_DIR=`pkg-config --variable=includedir libopenjpeg` \
-DPYTHON_EXECUTABLE=/usr/bin/python2 ..
make || return 1