summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandr Beliaev2021-11-23 19:56:37 +1300
committerAleksandr Beliaev2021-11-23 19:56:37 +1300
commit95cb9d53f9bf164bcffacb9a049601ec24d17b0f (patch)
tree3e381a15e7f802f9c1cd1a2bc16fc88518ba1013
downloadaur-95cb9d53f9bf164bcffacb9a049601ec24d17b0f.tar.gz
Classic GridWars with patches to work in modern Linux
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
-rw-r--r--gridwars.desktop18
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51a5f579a34f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gridwars-git
+ pkgdesc = Grid Wars 2: A clone of Geometry Wars
+ pkgver = r14.7249699
+ pkgrel = 1
+ url = http://gridwars.marune.de/
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = libglvnd
+ depends = libxdmcp
+ depends = libxxf86vm
+ depends = libxau
+ depends = libxft
+ depends = libx11
+ depends = glu
+ source = https://github.com/bmx-ng/bmx-ng/releases/download/v0.129.3.45.linux.x64/BlitzMax_linux_x64_0.129.3.45.tar.xz
+ source = git+https://github.com/trap000d/GridWars.git
+ source = gridwars.desktop
+ sha256sums = 635108f2b93d654934ae2baf15698082e2f21f070d6872da8e42bb9d4e331447
+ sha256sums = SKIP
+ sha256sums = 2ad4d272c2d4696b27eb3f8c5bff3b9d0c540703680124796c147cbf11eabb8e
+
+pkgname = gridwars-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57350150b3ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: trap000d <trap000d at gmail dot com>
+
+pkgname=gridwars-git
+pkgver=r14.7249699
+pkgrel=1
+pkgdesc="Grid Wars 2: A clone of Geometry Wars"
+_bmver="0.129.3.45"
+_srcname="GridWars"
+arch=('x86_64')
+url="http://gridwars.marune.de/"
+license=('GPL')
+depends=('libglvnd' 'libxdmcp' 'libxxf86vm' 'libxau' 'libxft' 'libx11' 'glu')
+makedepends=('git')
+source=("https://github.com/bmx-ng/bmx-ng/releases/download/v${_bmver}.linux.x64/BlitzMax_linux_x64_0.129.3.45.tar.xz"
+ "git+https://github.com/trap000d/GridWars.git"
+ "gridwars.desktop")
+sha256sums=('635108f2b93d654934ae2baf15698082e2f21f070d6872da8e42bb9d4e331447'
+ 'SKIP'
+ '2ad4d272c2d4696b27eb3f8c5bff3b9d0c540703680124796c147cbf11eabb8e')
+
+pkgver() {
+ cd ${srcdir}/${_srcname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ export PATH=${srcdir}/BlitzMax/bin:$PATH
+ cd ${srcdir}/${_srcname}
+ bmk makeapp -t gui -r -w gridwars.bmx
+}
+
+package() {
+
+ #Creating Directories
+ install -m755 -d $pkgdir/usr/{bin,share/{applications,pixmaps,games/gridwars/{gfx/{high,med,low,solid,user},music,sounds}}}
+
+ # Installing
+ install -D -m755 $srcdir/${_srcname}/gridwars $pkgdir/usr/share/games/gridwars/
+ install -D -m644 $srcdir/${_srcname}/gfx/colourpick.png $pkgdir/usr/share/games/gridwars/gfx/colourpick.png
+ for i in high low med solid user; do
+ install -D -m644 $srcdir/${_srcname}/gfx/$i/* $pkgdir/usr/share/games/gridwars/gfx/$i
+ done
+ install -D -m644 $srcdir/${_srcname}/music/* $pkgdir/usr/share/games/gridwars/music/
+ install -D -m644 $srcdir/${_srcname}/sounds/* $pkgdir/usr/share/games/gridwars/sounds/
+ install -D -m644 $srcdir/gridwars.desktop $pkgdir/usr/share/applications/gridwars.desktop
+ install -D -m644 $srcdir/${_srcname}/gfx/high/whiteplayer.png $pkgdir/usr/share/pixmaps/gridwars.png
+
+ # Linking binary and stuff
+ ln -sf /usr/share/games/gridwars/gridwars $pkgdir/usr/bin/gridwars
+}
diff --git a/gridwars.desktop b/gridwars.desktop
new file mode 100644
index 000000000000..f96ff20b480a
--- /dev/null
+++ b/gridwars.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Encoding=UTF-8
+Name=GridWars 2
+Name[en]=GridWars 2
+Name[fr]=GridWars 2
+GenericName=A Geometry Wars clone
+GenericName[en]=A Geometry Wars clone
+GenericName[fr]=Un clone de Geometry Wars
+Comment=A shoot-them-up taking place on a magnetic grid where you must survive to enemies waves.
+Comment[en]=A shoot-them-up taking place on a magnetic grid where you must survive to enemies waves.
+Comment[fr]=Un shoot-them-up prenant place sur une grille magnétique ou vous devez survivre à de multiples vagues d'ennemies.
+Icon=gridwars
+Exec=gridwars
+Terminal=false
+StartupNotify=false
+Categories=Application;Game;ArcadeGame