summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2015-06-09 13:10:27 +0200
committerValHue2015-06-09 13:10:27 +0200
commit60056ab592b08e8de1081d6f1ef8ec577f3b1797 (patch)
treec5d687e5e2d3c39d4667a824cd8439f60f43293f
downloadaur-60056ab592b08e8de1081d6f1ef8ec577f3b1797.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD58
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7dc8b3a37ceb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = griffith
+ pkgdesc = Movie collection manager application
+ pkgver = 0.13
+ pkgrel = 8
+ url = http://www.griffith.cc/
+ arch = any
+ license = GPL2
+ depends = pygtk>=2.14.1
+ depends = sqlite
+ depends = python2-pysqlite
+ depends = python2-reportlab>=2.3
+ depends = python2-pillow
+ depends = python2-sqlalchemy
+ optdepends = python2-psycopg2: postgreSQL support
+ optdepends = mysql-python: MySQL support
+ optdepends = python2-chardet: encoding detection of imported CSV files
+ optdepends = python2-gtkspell: spell checking support
+ optdepends = griffith-extra-artwork: additional icons
+ source = http://launchpad.net/griffith/trunk/0.13/+download/griffith-0.13.tar.gz
+ source = https://raw.githubusercontent.com/ValHue/AUR-PKGBUILDs/master/griffith/validators.py
+ source = http://www.strits.dk/files/PluginMovieIMDB.py
+ sha256sums = 60576d33aa855ab45d654288d7bf2ead8accecb72fd2acbc373656294ab8f242
+ sha256sums = f5e0b43c6ee56148b55cc650599c96b7774491867d38b47278bc121bf33fb9af
+ sha256sums = 3500b6f25fdbf8ebae40c38a5ba0c95a0ff27f74961b6d1cdc975b27adcc5cdf
+
+pkgname = griffith
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e6158266a79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: Jaroslav Lichtblau <dragonlord at aur dot archlinux dot org>
+# Contributor: Daniel J Griffiths <ghost1227 at archlinux dot us>
+# Contributor: Ronald van Haren <ronald at archlinux dot org>
+# Contributor: Alessio 'mOLOk' Bolognino <themolok at gmail dot com>
+# Contributor: Pawel Rusinek <p.rusinek at gmail dot com>
+
+pkgname="griffith"
+pkgver=0.13
+pkgrel=8
+pkgdesc="Movie collection manager application"
+arch=('any')
+url="http://www.griffith.cc/"
+license=('GPL2')
+depends=('pygtk>=2.14.1' 'sqlite' 'python2-pysqlite' \
+ 'python2-reportlab>=2.3' 'python2-pillow' 'python2-sqlalchemy')
+optdepends=('python2-psycopg2: postgreSQL support'
+ 'mysql-python: MySQL support'
+ 'python2-chardet: encoding detection of imported CSV files'
+ 'python2-gtkspell: spell checking support'
+ 'griffith-extra-artwork: additional icons')
+source=("http://launchpad.net/${pkgname}/trunk/0.13/+download/${pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/ValHue/AUR-PKGBUILDs/master/griffith/validators.py"
+ "http://www.strits.dk/files/PluginMovieIMDB.py")
+sha256sums=('60576d33aa855ab45d654288d7bf2ead8accecb72fd2acbc373656294ab8f242'
+ 'f5e0b43c6ee56148b55cc650599c96b7774491867d38b47278bc121bf33fb9af'
+ '3500b6f25fdbf8ebae40c38a5ba0c95a0ff27f74961b6d1cdc975b27adcc5cdf')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+
+ # python2 fix
+ sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' griffith
+
+ # new bash_completion directory
+ #sed -e 's,BASHCOMPDIR = $\(ETCDIR\)/bash_completion.d,BASHCOMPDIR = $\(PREFIX\)/share/bash-completion/completions,' -i Makefile
+ sed -e 's,BASHCOMPDIR = $(ETCDIR)/bash_completion.d,BASHCOMPDIR = $(PREFIX)/share/bash-completion/completions,' -i Makefile
+
+ # The version 0.13.0 of griffith isn't compatible with SqlAlchemy 0.8.
+ # http://forum.griffith.cc/index.php/topic,1601.msg5317.html#msg5317
+ cp -f ../validators.py ./lib/db/validators.py
+
+ # Update PluginMovieIMDB.py to version 1.15. Thanks to Strit
+ # http://www.strits.dk/files/PluginMovieIMDB.py
+ cp -f ../PluginMovieIMDB.py ./lib/plugins/movie/PluginMovieIMDB.py
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR=${pkgdir} install
+
+ # The program creates a wrong symlink so make a new one
+ rm ${pkgdir}/usr/bin/griffith
+ ln -s /usr/share/griffith/lib/griffith ${pkgdir}/usr/bin/griffith
+}