summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2017-01-08 22:30:40 +0100
committerValHue2017-01-08 22:30:40 +0100
commita4e59726a8c440154c9816937036f1070f2678d6 (patch)
treef4458581bd75dd5b2eba1a63decc41d21ff32288
parent9a1566c7ae4ac24bf9586a5f622fafd2b8805e8f (diff)
downloadaur-a4e59726a8c440154c9816937036f1070f2678d6.tar.gz
Update to 0.13-11
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6cf8b07de640..6e39b3591c32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = griffith
pkgdesc = Movie collection manager application
pkgver = 0.13
- pkgrel = 10
+ pkgrel = 11
url = http://www.griffith.cc/
arch = any
license = GPL2
- depends = pygtk>=2.14.1
+ depends = pygtk
depends = sqlite
depends = python2-pysqlite
- depends = python2-reportlab>=2.3
+ depends = python2-reportlab
depends = python2-pillow
depends = python2-sqlalchemy
optdepends = python2-psycopg2: postgreSQL support
diff --git a/PKGBUILD b/PKGBUILD
index 18942c8873a2..5d9d6a29bf82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,24 +9,28 @@
pkgname="griffith"
pkgver=0.13
-pkgrel=10
+pkgrel=11
pkgdesc="Movie collection manager application"
arch=('any')
url="http://www.griffith.cc/"
license=('GPL2')
-depends=('pygtk>=2.14.1' 'sqlite' 'python2-pysqlite' \
- 'python2-reportlab>=2.3' 'python2-pillow' 'python2-sqlalchemy')
+depends=('pygtk' 'sqlite' 'python2-pysqlite' \
+ 'python2-reportlab' 'python2-pillow' 'python2-sqlalchemy'
+)
optdepends=('python2-psycopg2: postgreSQL support'
'mysql-python: MySQL support'
'python2-chardet: encoding detection of imported CSV files'
'python2-gtkspell: spell checking support'
- 'griffith-extra-artwork: additional icons')
+ 'griffith-extra-artwork: additional icons'
+)
source=("http://launchpad.net/${pkgname}/trunk/0.13/+download/${pkgname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/ValHue/AUR-PKGBUILDs/master/griffith/validators.py"
- "http://www.strits.dk/files/PluginMovieIMDB.py")
+ "https://raw.githubusercontent.com/ValHue/AUR-PKGBUILDs/master/griffith/validators.py"
+ "http://www.strits.dk/files/PluginMovieIMDB.py"
+)
sha256sums=('60576d33aa855ab45d654288d7bf2ead8accecb72fd2acbc373656294ab8f242'
'f5e0b43c6ee56148b55cc650599c96b7774491867d38b47278bc121bf33fb9af'
- 'c1f1c5dbe0b975f15a6d0265e53b993390eb33aca2011f2e0d390b326a017a21')
+ 'c1f1c5dbe0b975f15a6d0265e53b993390eb33aca2011f2e0d390b326a017a21'
+)
build() {
cd "${pkgname}-${pkgver}"
@@ -45,6 +49,12 @@ build() {
# Update PluginMovieIMDB.py to version 1.15. Thanks to Strit
# http://www.strits.dk/files/PluginMovieIMDB.py
cp -f ../PluginMovieIMDB.py ./lib/plugins/movie/PluginMovieIMDB.py
+
+ # Fix dependencies version
+ sed -i '65,83d' griffith
+
+ # Fix to AttributeError: 'module' object has no attribute 'glade'
+ sed -i "35i\import gtk.glade" ./lib/initialize.py
}
package() {
@@ -53,7 +63,7 @@ package() {
make DESTDIR=${pkgdir} install
# The program creates a wrong symlink so make a new one
- rm ${pkgdir}/usr/bin/griffith
- ln -s /usr/share/griffith/lib/griffith ${pkgdir}/usr/bin/griffith
+ rm ${pkgdir}/usr/bin/griffith
+ ln -s ${pkgdir}/usr/share/griffith/lib/griffith ${pkgdir}/usr/bin/griffith
}
# vim:set ts=4 sw=2 ft=sh et: