summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2015-06-11 08:39:46 +0200
committerCarsten Feuls2015-06-11 08:39:46 +0200
commit3c0aba98888ce21657f1f0ebfb63ef01b2a432c5 (patch)
tree553b7feb3c437340b289d47d76ae6973a1a72910
downloadaur-3c0aba98888ce21657f1f0ebfb63ef01b2a432c5.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
-rw-r--r--g_thread.patch12
-rw-r--r--grig.desktop7
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abf121715d29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = grig
+ pkgdesc = Rig control (cat) program
+ pkgver = 0.8.0
+ pkgrel = 4
+ url = http://groundstation.sourceforge.net/grig/
+ arch = i686
+ arch = x86_64
+ arch = armv5h
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ depends = hamlib
+ depends = gtk2
+ source = http://downloads.sourceforge.net/groundstation/grig-0.8.0.tar.gz
+ source = grig.desktop
+ source = g_thread.patch
+ sha256sums = d621a3400b7720d6671d18bff2e7627cc1442d58df161cc8789851300495d3f3
+ sha256sums = d216d4bbc8e364a2ed3066659e694204451a7f182a9448df9acb1d8c85808c5c
+ sha256sums = 77a25f821356528a732c08970ca05b9f556564e4517e16304fa14a172040f165
+
+pkgname = grig
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ef6b76172bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de> aka DL1CAF
+
+pkgname=grig
+pkgver=0.8.0
+pkgrel=4
+pkgdesc="Rig control (cat) program"
+arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
+url="http://groundstation.sourceforge.net/grig/"
+license=('GPL')
+depends=('hamlib' 'gtk2')
+source=("http://downloads.sourceforge.net/groundstation/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}.desktop"
+ "g_thread.patch")
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ sed -i -e "s:GtkTooltips:GtkTooltip:" src/grig-gtk-workarounds.c
+ sed -i -e "s:GtkTooltips:GtkTooltip:" src/rig-gui-vfo.c
+ sed -i -e "s:GtkTooltips:GtkTooltip:" src/rig-gui-buttons.c
+ sed -i -e "s:GtkTooltips:GtkTooltip:" src/rig-gui-levels.c
+ patch -p1 -i ${srcdir}/g_thread.patch src/main.c
+ LIBS=-lm ./configure --prefix=/usr
+ make
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/applications
+ install -m644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications
+ cd ${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+ rm -r ${pkgdir}/usr/share/${pkgname}
+}
+
+sha256sums=('d621a3400b7720d6671d18bff2e7627cc1442d58df161cc8789851300495d3f3'
+ 'd216d4bbc8e364a2ed3066659e694204451a7f182a9448df9acb1d8c85808c5c'
+ '77a25f821356528a732c08970ca05b9f556564e4517e16304fa14a172040f165')
diff --git a/g_thread.patch b/g_thread.patch
new file mode 100644
index 000000000000..27a85938500c
--- /dev/null
+++ b/g_thread.patch
@@ -0,0 +1,12 @@
+--- main.c 2011-06-27 12:02:28.000000000 +0200
++++ main.c 2014-07-14 17:06:44.649235990 +0200
+@@ -182,8 +182,7 @@
+ the program if threads are not supported... then why doesn''t it work
+ on FreeBSD?
+ */
+- if (!g_thread_supported ())
+- g_thread_init (NULL);
++ g_thread_init (NULL);
+
+
+
diff --git a/grig.desktop b/grig.desktop
new file mode 100644
index 000000000000..1af7acc65e8e
--- /dev/null
+++ b/grig.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=grig
+Comment=Rig control (cat) program
+Exec=grig
+StartupNotify=true
+Type=Application
+Categories=HamRadio;