summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2021-08-21 14:22:12 -0600
committernot_anonymous2021-08-21 14:22:12 -0600
commit53725d352348166fd17366c9813229279edfb931 (patch)
tree9a5983078861a707ba6ee17137fa3bfc57f6ad11
parentd13d3f947cb696ada39a58cbc38fd85983381165 (diff)
downloadaur-53725d352348166fd17366c9813229279edfb931.tar.gz
Updated
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD55
-rw-r--r--g_thread.patch12
4 files changed, 47 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d6f40a2341a..44dc07aaa867 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Feb 14 13:24:19 UTC 2016
pkgbase = grig
- pkgdesc = Rig control (cat) program
+ pkgdesc = Ham Radio - Rig control (cat) program
pkgver = 0.8.1
- pkgrel = 1
+ pkgrel = 3
url = http://groundstation.sourceforge.net/grig/
arch = i686
arch = x86_64
@@ -11,15 +9,18 @@ pkgbase = grig
arch = armv6h
arch = armv7h
license = GPL
- depends = hamlib
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = intltool
+ makedepends = pkg-config
+ depends = hamlib=3.3
depends = gtk2
- depends = intltool
+ depends = hamradio-menus
source = http://downloads.sourceforge.net/groundstation/grig-0.8.1.tar.gz
source = grig.desktop
- source = g_thread.patch
+ md5sums = a9c0bbd58ba48d01a2fc4bcdc7bc44fc
+ md5sums = e652ce82c1fbf8ead412e978921d8025
sha256sums = be8687418fb23efa0468674c3fdd15340fed06eef09be9de21106cc17e033c25
- sha256sums = d216d4bbc8e364a2ed3066659e694204451a7f182a9448df9acb1d8c85808c5c
- sha256sums = 77a25f821356528a732c08970ca05b9f556564e4517e16304fa14a172040f165
+ sha256sums = 85941679f966eab51a5f90450447cc4b321040978287b7066f8edb1cd0bf537a
pkgname = grig
-
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 36ae5c471682..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,6 +0,0 @@
-*
-!PKGBUILD
-!.SRCINFO
-!.gitignore
-!*.desktop
-!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index e21c3367af3f..3bbc4569ba15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,53 @@
-# Maintainer: Carsten Feuls <archlinux@carstenfeuls.de> aka DL1CAF
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+# Contrubutor: Carsten Feuls <archlinux@carstenfeuls.de> aka DL1CAF
+# Contributor: [Vitaliy Berdinskikh](mailto:ur6lad@archlinux.org.ua) aka UR6LAD
+# Original Submission: Bob Finch <w9ya@qrparci.net>
pkgname=grig
pkgver=0.8.1
-pkgrel=1
-pkgdesc="Rig control (cat) program"
+pkgrel=3
+pkgdesc="Ham Radio - Rig control (cat) program"
arch=('i686' 'x86_64' 'armv5h' 'armv6h' 'armv7h')
url="http://groundstation.sourceforge.net/grig/"
license=('GPL')
-depends=('hamlib' 'gtk2' 'intltool')
-source=("http://downloads.sourceforge.net/groundstation/${pkgname}-${pkgver}.tar.gz"
- "${pkgname}.desktop"
- "g_thread.patch")
-sha256sums=('be8687418fb23efa0468674c3fdd15340fed06eef09be9de21106cc17e033c25'
- 'd216d4bbc8e364a2ed3066659e694204451a7f182a9448df9acb1d8c85808c5c'
- '77a25f821356528a732c08970ca05b9f556564e4517e16304fa14a172040f165')
+depends=('hamlib=3.3' 'gtk2' 'hamradio-menus')
+makedepends=('autoconf' 'automake' 'intltool' 'pkg-config')
+source=("http://downloads.sourceforge.net/groundstation/$pkgname-$pkgver.tar.gz"
+ "$pkgname.desktop")
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
sed -i -e "s:GtkTooltips:GtkTooltip:" src/grig-gtk-workarounds.c
sed -i -e "s:GtkTooltips:GtkTooltip:" src/rig-gui-vfo.c
sed -i -e "s:GtkTooltips:GtkTooltip:" src/rig-gui-buttons.c
sed -i -e "s:GtkTooltips:GtkTooltip:" src/rig-gui-levels.c
- #patch -p1 -i ${srcdir}/g_thread.patch src/main.c
- LIBS=-lm ./configure --prefix=/usr
+
+ autoreconf -i
+}
+
+build(){
+ cd $srcdir/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
make
}
package() {
- mkdir -p ${pkgdir}/usr/share/applications
- install -m644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications
- cd ${pkgname}-${pkgver}
+ cd $srcdir/$pkgname-$pkgver
+
make DESTDIR=${pkgdir} install
- rm -r ${pkgdir}/usr/share/${pkgname}
-}
+ mkdir -p $pkgdir/usr/share/applications
+ install -D -m 644 ../$pkgname.desktop $pkgdir/usr/share/applications
+
+ cd $pkgdir/usr/share/pixmaps/grig
+ cp -a $pkgname-logo.png ../.
+
+ rm -r $pkgdir/usr/share/$pkgname
+}
+md5sums=('a9c0bbd58ba48d01a2fc4bcdc7bc44fc'
+ 'e652ce82c1fbf8ead412e978921d8025')
+sha256sums=('be8687418fb23efa0468674c3fdd15340fed06eef09be9de21106cc17e033c25'
+ '85941679f966eab51a5f90450447cc4b321040978287b7066f8edb1cd0bf537a')
diff --git a/g_thread.patch b/g_thread.patch
deleted file mode 100644
index 27a85938500c..000000000000
--- a/g_thread.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- main.c 2011-06-27 12:02:28.000000000 +0200
-+++ main.c 2014-07-14 17:06:44.649235990 +0200
-@@ -182,8 +182,7 @@
- the program if threads are not supported... then why doesn''t it work
- on FreeBSD?
- */
-- if (!g_thread_supported ())
-- g_thread_init (NULL);
-+ g_thread_init (NULL);
-
-
-