summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2018-08-07 10:46:10 +0100
committeremersion2018-08-07 14:33:44 +0100
commit6bc27b261abf36f28ecf41e5d77d9076edeaeb8e (patch)
treebc9277efbc85e23c2bb72a1c959614c82d13b339
parent78e57171a36f1d806417429ab3abe06ae821523f (diff)
downloadaur-6bc27b261abf36f28ecf41e5d77d9076edeaeb8e.tar.gz
Fix the size of the commit hash in the package version
This allows the build on different machine to show up as the same version, avoiding unnecessarily incorrect "out of date" messages.
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac359cbabc1d..f85cced6d3b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ conflicts=('grim')
pkgver() {
cd "${srcdir}/${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {