summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2024-02-06 23:04:27 +0300
committerArtem Vorotnikov2024-02-06 23:22:12 +0300
commit51e088bb490637c49335569c1f6aadf5cf934942 (patch)
tree23f77e7f5ea39f79dbb27ce19d3b4dbac2d467b8
parentbd31b137894c73d58877bdc8059e1b38b4b76aa2 (diff)
downloadaur-grin.tar.gz
Update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
-rw-r--r--grin-server.toml30
3 files changed, 55 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76273d641e5..6086e85b55b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,20 @@
pkgbase = grin
pkgdesc = Minimal implementation of the MimbleWimble protocol
- pkgver = 4.0.2
+ pkgver = 5.2.0
pkgrel = 1
url = https://github.com/mimblewimble/grin
- arch = i686
- arch = x86_64
- license = Apache
+ arch = any
+ license = Apache-2.0
makedepends = clang
makedepends = git
- makedepends = rust
+ makedepends = cargo
depends = ncurses
backup = etc/grin/server.toml
- source = git+https://github.com/mimblewimble/grin.git#tag=v4.0.2
+ source = grin-5.2.0.tar.gz::https://static.crates.io/crates/grin/grin-5.2.0.crate
source = grin-server.service
source = grin-server.toml
- sha256sums = SKIP
- sha256sums = 5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9
- sha256sums = f44c95c1576d8edf48e182602c4b4f85f7c8ceb090c97d107c011f64bd4c1885
+ b2sums = 1a3b09274f07b0d95662b1388ac70b364173bf81bc55e1561fbb5848b81f3d1ad7f2524091428a5d73eb1e338f727ef9822e23e435ac17dc6e0de8d8e59d6839
+ b2sums = 927c417ca92bf5dd024dc712b088789a7590555fde7b043ac1c39eec7c8a8ef28df3348cc49b49220c2dbfb5f01452f0757d4368172256d3b014445c612b21c1
+ b2sums = 24a5cf856e9e316aa6bdb8a6156546b34e266689f088a3ecd0796975db027a016fdef916839df5f270d15ced47c324b87e6afa68a09ab87c396150974a153e07
pkgname = grin
-
diff --git a/PKGBUILD b/PKGBUILD
index 2e13682ee5cd..bb5472710272 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,45 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
-# Contributor: Nicola Squartini <tensor5@gmail.com>
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
pkgname=grin
-pkgver=4.0.2
+pkgver=5.2.0
pkgrel=1
pkgdesc='Minimal implementation of the MimbleWimble protocol'
-arch=('i686' 'x86_64')
+arch=('any')
url='https://github.com/mimblewimble/grin'
-license=('Apache')
+license=('Apache-2.0')
depends=('ncurses')
-makedepends=('clang' 'git' 'rust')
+makedepends=('clang' 'git' 'cargo')
backup=('etc/grin/server.toml')
-source=("git+https://github.com/mimblewimble/grin.git#tag=v${pkgver}"
+source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate"
'grin-server.service'
'grin-server.toml')
-sha256sums=('SKIP'
- '5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9'
- 'f44c95c1576d8edf48e182602c4b4f85f7c8ceb090c97d107c011f64bd4c1885')
+b2sums=('1a3b09274f07b0d95662b1388ac70b364173bf81bc55e1561fbb5848b81f3d1ad7f2524091428a5d73eb1e338f727ef9822e23e435ac17dc6e0de8d8e59d6839'
+ '927c417ca92bf5dd024dc712b088789a7590555fde7b043ac1c39eec7c8a8ef28df3348cc49b49220c2dbfb5f01452f0757d4368172256d3b014445c612b21c1'
+ '24a5cf856e9e316aa6bdb8a6156546b34e266689f088a3ecd0796975db027a016fdef916839df5f270d15ced47c324b87e6afa68a09ab87c396150974a153e07')
+
+prepare() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
+}
build() {
- cd ${pkgname}
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
- cargo build --release
+check() {
+ cd $pkgname-$pkgver
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
}
package() {
- cd ${pkgname}
+ cd $pkgname-$pkgver
- install -Dm755 -t "${pkgdir}/usr/bin" target/release/grin
- install -Dm644 -t "${pkgdir}/usr/lib/systemd/system" ../grin-server.service
- install -Dm644 ../grin-server.toml "${pkgdir}/etc/grin/server.toml"
+ install -Dm0755 -t "$pkgdir/usr/bin" "target/release/$pkgname"
+ install -Dm0644 -t "$pkgdir/usr/lib/systemd/system" ../grin-server.service
+ install -Dm0644 ../grin-server.toml "$pkgdir/etc/grin/server.toml"
}
diff --git a/grin-server.toml b/grin-server.toml
index 812f3489c5c0..4f685d9fedcd 100644
--- a/grin-server.toml
+++ b/grin-server.toml
@@ -9,6 +9,8 @@
# -[user home]/.grin
#
+config_file_version = 2
+
#########################################
### SERVER CONFIGURATION ###
#########################################
@@ -40,10 +42,18 @@ foreign_api_secret_path = ".foreign_api_secret"
#parameters used for mining as well as wallet output coinbase maturity. Can be:
#AutomatedTesting - For CI builds and instant blockchain creation
#UserTesting - For regular user testing (cuckoo 16)
-#Floonet - For the long term floonet test network
+#Testnet - For the long term test network
#Mainnet - For mainnet
chain_type = "Mainnet"
+#The Future Time Limit (FTL) is a limit on how far into the future,
+#relative to a node's local time, the timestamp on a new block can be,
+#in order for the block to be accepted.
+#At Hard Fork 4, this was reduced from 12 minutes down to 5 minutes,
+#so as to limit possible timestamp manipulation on the new
+#wtema difficulty adjustment algorithm
+future_time_limit = 300
+
#the chain validation mode, defines how often (if at all) we
#want to run a full chain validation. Can be:
#"EveryBlock" - run full chain validation when processing each block (except during sync)
@@ -81,6 +91,7 @@ host = "0.0.0.0"
#The port on which to listen.
port = 3414
+#All seeds/peers can be either IP address or DNS names. Port number must always be specified
#how to seed this server, can be None, List or DNSSeed
seeding_type = "DNSSeed"
@@ -112,23 +123,20 @@ seeding_type = "DNSSeed"
#amount of incoming connections temporarily allowed to exceed peer_max_inbound_count
#peer_listener_buffer_count = 8
-# 15 = Bit flags for FULL_NODE
-#This structure needs to be changed internally, to make it more configurable
-
# A preferred dandelion_peer, mainly used for testing dandelion
# dandelion_peer = "10.0.0.1:13144"
-[server.p2p_config.capabilities]
-bits = 15
-
-
#########################################
### MEMPOOL CONFIGURATION ###
#########################################
[server.pool_config]
#base fee that's accepted into the pool
-accept_fee_base = 1000000
+accept_fee_base = 500000
+
+#reorg cache retention period in minute.
+#the reorg cache repopulates local mempool in a reorg scenario.
+reorg_cache_period = 30
#maximum number of transactions allowed in the pool
max_pool_size = 50000
@@ -219,10 +227,10 @@ timeout = 10
log_to_stdout = true
#log level for stdout: Error, Warning, Info, Debug, Trace
-stdout_log_level = "Warning"
+stdout_log_level = "Info"
#whether to log to a file
-log_to_file = true
+log_to_file = false
#log level for file: Error, Warning, Info, Debug, Trace
file_log_level = "Info"