summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Squartini2019-06-27 14:23:16 +0900
committerNicola Squartini2019-06-27 14:23:16 +0900
commit0735565581e453911e1a90916d4a051689d64e72 (patch)
tree64ba0be9c3c5c2436c62a23290ce256d527e6c93
parent9d4aa22f76c15aa4bbe0b211c0f33c850cfa5457 (diff)
downloadaur-0735565581e453911e1a90916d4a051689d64e72.tar.gz
Update to 1.1.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--grin-server.toml36
3 files changed, 36 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 112f718e19d2..98bb404fe9bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grin
pkgdesc = Minimal implementation of the MimbleWimble protocol
- pkgver = 1.0.3
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/mimblewimble/grin
arch = i686
@@ -11,12 +11,12 @@ pkgbase = grin
makedepends = rust
depends = ncurses
backup = etc/grin/server.toml
- source = git+https://github.com/mimblewimble/grin.git#commit=4f52209cd01c90066683df59e3629d6d93bf94f0
+ source = git+https://github.com/mimblewimble/grin.git#commit=a89a1024b6dd7cc5d3def6b41edae0e46b55658d
source = grin-server.service
source = grin-server.toml
sha256sums = SKIP
sha256sums = 5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9
- sha256sums = 4478b8ecf0f7d3e9519bec0f03f969b7b4f3247f7abb5dd8bc25b2e6a5cbb39f
+ sha256sums = 6299aee995452c807e382a1bb4f316725295f69b567df51b31391409781481cd
pkgname = grin
diff --git a/PKGBUILD b/PKGBUILD
index a710cbe9d4c7..8b9f937945f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
pkgname=grin
-pkgver=1.0.3
-_commit=4f52209cd01c90066683df59e3629d6d93bf94f0
+pkgver=1.1.0
+_commit=a89a1024b6dd7cc5d3def6b41edae0e46b55658d
pkgrel=1
pkgdesc='Minimal implementation of the MimbleWimble protocol'
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ source=("git+https://github.com/mimblewimble/grin.git#commit=${_commit}"
'grin-server.toml')
sha256sums=('SKIP'
'5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9'
- '4478b8ecf0f7d3e9519bec0f03f969b7b4f3247f7abb5dd8bc25b2e6a5cbb39f')
+ '6299aee995452c807e382a1bb4f316725295f69b567df51b31391409781481cd')
build() {
cd ${pkgname}
diff --git a/grin-server.toml b/grin-server.toml
index 2c44659efd4c..bebfec24c568 100644
--- a/grin-server.toml
+++ b/grin-server.toml
@@ -29,7 +29,7 @@ db_root = "/var/lib/grin/main/chain_data"
api_http_addr = "127.0.0.1:3413"
#path of the secret token used by the API to authenticate the calls
-#comment it to disable basic auth
+#comment the it to disable basic auth
api_secret_path = "/var/lib/grin/main/.api_secret"
#The chain type, which defines the genesis block and the set of cuckoo
@@ -97,7 +97,7 @@ seeding_type = "DNSSeed"
#ban_window = 10800
#maximum number of peers
-#peer_max_count = 25
+#peer_max_count = 125
#preferred minimum number of peers (we'll actively keep trying to add peers
#until we get to at least this number
@@ -136,14 +136,14 @@ mineable_max_weight = 40000
#########################################
[server.dandelion_config]
-#dandelion relay time (choose new relay peer every n secs)
-relay_secs = 600
+#dandelion epoch duration
+epoch_secs = 600
#fluff and broadcast after embargo expires if tx not seen on network
embargo_secs = 180
-#run dandelion stem/fluff processing every n secs (stem tx aggregation in this window)
-patience_secs = 10
+#dandelion aggregation period in secs
+aggregation_secs = 30
#dandelion stem probability (stem 90% of the time, fluff 10% of the time)
stem_probability = 90
@@ -175,6 +175,30 @@ burn_reward = false
#########################################
+### WEBHOOK CONFIGURATION ###
+#########################################
+[server.webhook_config]
+
+#The url where a POST request will be sent when a new block is accepted by our node.
+#block_accepted_url = "http://127.0.0.1:8080/acceptedblock"
+
+#The url where a POST request will be sent when a new transaction is received by a peer.
+#tx_received_url = "http://127.0.0.1:8080/tx"
+
+#The url where a POST request will be sent when a new header is received by a peer.
+#header_received_url = "http://127.0.0.1:8080/header"
+
+#The url where a POST request will be sent when a new block is received by a peer.
+#block_received_url = "http://127.0.0.1:8080/block"
+
+#The number of worker threads that will be assigned to making the http requests.
+nthreads = 4
+
+#The timeout of the http request in seconds.
+timeout = 10
+
+
+#########################################
### LOGGING CONFIGURATION ###
#########################################
[logging]