summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Squartini2020-01-12 11:13:19 +0100
committerNicola Squartini2020-01-12 11:13:19 +0100
commit47807986b3ea2c4e07e84c195067fb8a03f37af3 (patch)
tree5160dbb8c0adb59863774640c97846d5aee3fdba
parent5e3e05db148a17ded10c00e9d1a79f86658d4fcb (diff)
downloadaur-47807986b3ea2c4e07e84c195067fb8a03f37af3.tar.gz
Update to 3.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--grin-server.toml9
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01455861b9bb..e53816a7c3de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grin
pkgdesc = Minimal implementation of the MimbleWimble protocol
- pkgver = 2.1.1
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/mimblewimble/grin
arch = i686
@@ -11,12 +11,12 @@ pkgbase = grin
makedepends = rust
depends = ncurses
backup = etc/grin/server.toml
- source = git+https://github.com/mimblewimble/grin.git#commit=6d1bc3a1f921d9d9ff51c739ff1b0fadc434881b
+ source = git+https://github.com/mimblewimble/grin.git#commit=4704037848261e09fe342469e31396eb205d8408
source = grin-server.service
source = grin-server.toml
sha256sums = SKIP
sha256sums = 5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9
- sha256sums = fa86d0075c1adfb6a92d0db8df6b5012250527f14f566dfb52fd64958b8bc04f
+ sha256sums = f44c95c1576d8edf48e182602c4b4f85f7c8ceb090c97d107c011f64bd4c1885
pkgname = grin
diff --git a/PKGBUILD b/PKGBUILD
index c3d282341be2..1b9bb4f8b43e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
pkgname=grin
-pkgver=2.1.1
-_commit=6d1bc3a1f921d9d9ff51c739ff1b0fadc434881b
+pkgver=3.0.0
+_commit=4704037848261e09fe342469e31396eb205d8408
pkgrel=1
pkgdesc='Minimal implementation of the MimbleWimble protocol'
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ source=("git+https://github.com/mimblewimble/grin.git#commit=${_commit}"
'grin-server.toml')
sha256sums=('SKIP'
'5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9'
- 'fa86d0075c1adfb6a92d0db8df6b5012250527f14f566dfb52fd64958b8bc04f')
+ 'f44c95c1576d8edf48e182602c4b4f85f7c8ceb090c97d107c011f64bd4c1885')
build() {
cd ${pkgname}
diff --git a/grin-server.toml b/grin-server.toml
index fa13189bcf26..812f3489c5c0 100644
--- a/grin-server.toml
+++ b/grin-server.toml
@@ -28,10 +28,14 @@ db_root = "/var/lib/grin/main/chain_data"
#the address on which services will listen, e.g. Transaction Pool
api_http_addr = "127.0.0.1:3413"
-#path of the secret token used by the API to authenticate the calls
+#path of the secret token used by the Rest API and v2 Owner API to authenticate the calls
#comment the it to disable basic auth
api_secret_path = "/var/lib/grin/main/.api_secret"
+#path of the secret token used by the Foreign API to authenticate the calls
+#comment the it to disable basic auth
+foreign_api_secret_path = ".foreign_api_secret"
+
#The chain type, which defines the genesis block and the set of cuckoo
#parameters used for mining as well as wallet output coinbase maturity. Can be:
#AutomatedTesting - For CI builds and instant blockchain creation
@@ -52,8 +56,7 @@ archive_mode = false
#skip waiting for sync on startup, (optional param, mostly for testing)
skip_sync_wait = false
-#whether to run the ncurses TUI. Ncurses must be installed and this
-#will also disable logging to stdout
+#whether to run the ncurses TUI (Ncurses must be installed)
run_tui = false
#Whether to run a test miner. This is only for developer testing (chaintype