summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Squartini2019-11-19 18:32:06 +0900
committerNicola Squartini2019-11-19 18:32:06 +0900
commit5e3e05db148a17ded10c00e9d1a79f86658d4fcb (patch)
tree8a810541148d7ef5654a644062b029e311d0fc63
parentb2276125c9b5ee19eefaaba9c3578a084dca61fd (diff)
downloadaur-5e3e05db148a17ded10c00e9d1a79f86658d4fcb.tar.gz
Update to 2.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--grin-server.toml19
3 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f497c50789db..01455861b9bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grin
pkgdesc = Minimal implementation of the MimbleWimble protocol
- pkgver = 2.0.0
+ pkgver = 2.1.1
pkgrel = 1
url = https://github.com/mimblewimble/grin
arch = i686
@@ -11,12 +11,12 @@ pkgbase = grin
makedepends = rust
depends = ncurses
backup = etc/grin/server.toml
- source = git+https://github.com/mimblewimble/grin.git#commit=8f3be49dfa152322c228352c1f34447328ac84d9
+ source = git+https://github.com/mimblewimble/grin.git#commit=6d1bc3a1f921d9d9ff51c739ff1b0fadc434881b
source = grin-server.service
source = grin-server.toml
sha256sums = SKIP
sha256sums = 5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9
- sha256sums = 6299aee995452c807e382a1bb4f316725295f69b567df51b31391409781481cd
+ sha256sums = fa86d0075c1adfb6a92d0db8df6b5012250527f14f566dfb52fd64958b8bc04f
pkgname = grin
diff --git a/PKGBUILD b/PKGBUILD
index 0c90679b3e78..c3d282341be2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Nicola Squartini <tensor5@gmail.com>
pkgname=grin
-pkgver=2.0.0
-_commit=8f3be49dfa152322c228352c1f34447328ac84d9
+pkgver=2.1.1
+_commit=6d1bc3a1f921d9d9ff51c739ff1b0fadc434881b
pkgrel=1
pkgdesc='Minimal implementation of the MimbleWimble protocol'
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ source=("git+https://github.com/mimblewimble/grin.git#commit=${_commit}"
'grin-server.toml')
sha256sums=('SKIP'
'5a9b2c30bd95d8ccb4666dcc97b2811c4b5ec501162b6178a1850b5b2fc95de9'
- '6299aee995452c807e382a1bb4f316725295f69b567df51b31391409781481cd')
+ 'fa86d0075c1adfb6a92d0db8df6b5012250527f14f566dfb52fd64958b8bc04f')
build() {
cd ${pkgname}
diff --git a/grin-server.toml b/grin-server.toml
index bebfec24c568..fa13189bcf26 100644
--- a/grin-server.toml
+++ b/grin-server.toml
@@ -96,12 +96,18 @@ seeding_type = "DNSSeed"
#how long a banned peer should stay banned
#ban_window = 10800
-#maximum number of peers
-#peer_max_count = 125
+#maximum number of inbound peer connections
+#peer_max_inbound_count = 128
-#preferred minimum number of peers (we'll actively keep trying to add peers
-#until we get to at least this number
-#peer_min_preferred_count = 8
+#maximum number of outbound peer connections
+#peer_max_outbound_count = 8
+
+#preferred minimum number of outbound peers (we'll actively keep trying to add peers
+#until we get to at least this number)
+#peer_min_preferred_outbound_count = 8
+
+#amount of incoming connections temporarily allowed to exceed peer_max_inbound_count
+#peer_listener_buffer_count = 8
# 15 = Bit flags for FULL_NODE
#This structure needs to be changed internally, to make it more configurable
@@ -148,6 +154,9 @@ aggregation_secs = 30
#dandelion stem probability (stem 90% of the time, fluff 10% of the time)
stem_probability = 90
+#always stem our (pushed via api) txs regardless of stem/fluff epoch (as per Dandelion++ paper)
+always_stem_our_txs = true
+
################################################
### STRATUM MINING SERVER CONFIGURATION ###