summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitba92b93f3eeaf31798d8a296bbada566b3da73dd (patch)
treea8a84642b0c24b4ac0e0a2f1cdd7dc65a5cfa0be
downloadaur-ba92b93f3eeaf31798d8a296bbada566b3da73dd.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--desktopfile.diff13
-rw-r--r--gringotts.diff40
-rw-r--r--gringotts.install19
6 files changed, 155 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..9fdbd5166022
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = gringotts
+ pkgdesc = Secure notes manager for UNIX-like systems.
+ pkgver = 1.2.10
+ pkgrel = 2
+ url = http://sourceforge.net/projects/gringotts.berlios/
+ install = gringotts.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = patch
+ depends = libgringotts
+ depends = gtk2
+ depends = popt
+ source = http://sourceforge.net/projects/gringotts.berlios/files/gringotts-1.2.10.tar.gz
+ source = gringotts.diff
+ source = desktopfile.diff
+
+pkgname = gringotts
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f3e43f4fe7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = gringotts
+ pkgdesc = Secure notes manager for UNIX-like systems.
+ pkgver = 1.2.10
+ pkgrel = 2
+ url = http://sourceforge.net/projects/gringotts.berlios/
+ install = gringotts.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = patch
+ depends = libgringotts
+ depends = gtk2
+ depends = popt
+ source = http://sourceforge.net/projects/gringotts.berlios/files/gringotts-1.2.10.tar.gz
+ source = gringotts.diff
+ source = desktopfile.diff
+ sha256sums = 19784f68f76b211d076124c74d2f5ca5a156e4af7ed32d72a1ba45547782179d
+ sha256sums = 44e26544d3d80db2804db6b769f53fc31d78cfd3a04c04b6f51c107bb09bac4f
+ sha256sums = 2068f465170d80ea4e2ed18addfd82c0fb73fed073f4926e45e91c99092292c1
+
+pkgname = gringotts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aff724a91c19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Jaroslav Lichtlbau <dragonlord@aur.archlinux.org>
+
+pkgname=gringotts
+pkgver=1.2.10
+pkgrel=2
+pkgdesc="Secure notes manager for UNIX-like systems."
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/gringotts.berlios/"
+license=('GPL')
+depends=('libgringotts' 'gtk2' 'popt')
+makedepends=('patch')
+install=$pkgname.install
+source=(http://sourceforge.net/projects/gringotts.berlios/files/$pkgname-$pkgver.tar.gz
+ $pkgname.diff
+ desktopfile.diff)
+sha256sums=('19784f68f76b211d076124c74d2f5ca5a156e4af7ed32d72a1ba45547782179d'
+ '44e26544d3d80db2804db6b769f53fc31d78cfd3a04c04b6f51c107bb09bac4f'
+ '2068f465170d80ea4e2ed18addfd82c0fb73fed073f4926e45e91c99092292c1')
+
+build() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
+
+#patching source code and the gringotts.desktop file
+ patch -Np0 -i "${srcdir}"/$pkgname.diff
+ patch -Np0 -i "${srcdir}"/desktopfile.diff
+
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ make DESTDIR="${pkgdir}" install
+
+#.desktop file
+ install -D -m644 $pkgname.desktop "${pkgdir}"/usr/share/applications/$pkgname.desktop
+
+#adding suid bit to the executable
+ chmod u+s "${pkgdir}"/usr/bin/$pkgname
+}
diff --git a/desktopfile.diff b/desktopfile.diff
new file mode 100644
index 000000000000..d7dd7b9ee7aa
--- /dev/null
+++ b/desktopfile.diff
@@ -0,0 +1,13 @@
+--- gringotts.desktop.orig 2008-09-04 17:48:18.000000000 +0200
++++ gringotts.desktop 2008-09-04 17:52:50.000000000 +0200
+@@ -5,4 +5,3 @@
+ Version=1.0
+-Encoding=UTF-8
+-Icon=/usr/share/pixmaps/gringotts.xpm
++Icon=gringotts
+ Exec=gringotts
+@@ -21 +20,4 @@
+ Comment[de]=Ein elektronischer "Tresor"
++Name[cs]=Gringotovi
++GenericName[cs]=Elektronický "trezor"
++Comment[cs]=Elektronický trezor
diff --git a/gringotts.diff b/gringotts.diff
new file mode 100644
index 000000000000..20ef33ba685f
--- /dev/null
+++ b/gringotts.diff
@@ -0,0 +1,40 @@
+--- src/Makefile 2008-02-10 18:02:36.000000000 +0100
+***************
+*** 481,490 ****
+ mostlyclean-compile mostlyclean-generic pdf pdf-am ps ps-am \
+ tags uninstall uninstall-am uninstall-binPROGRAMS
+
+-
+- install-exec-local:
+- strip $(DESTDIR)$(bindir)/gringotts
+- chmod u+s $(DESTDIR)$(bindir)/gringotts
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
+--- 481,486 ----
+--- src/Makefile.am 2008-02-10 18:03:06.000000000 +0100
+***************
+*** 29,36 ****
+ grg_defs.h
+
+ gringotts_LDADD = @POPT@ @GTK2_LIBS@ @GDKPIX_LIBS@ @LIBGRG_LIBS@
+-
+- install-exec-local:
+- strip $(DESTDIR)$(bindir)/gringotts
+- chmod u+s $(DESTDIR)$(bindir)/gringotts
+-
+--- 29,31 ----
+--- src/Makefile.in 2008-02-10 18:03:24.000000000 +0100
+***************
+*** 481,490 ****
+ mostlyclean-compile mostlyclean-generic pdf pdf-am ps ps-am \
+ tags uninstall uninstall-am uninstall-binPROGRAMS
+
+-
+- install-exec-local:
+- strip $(DESTDIR)$(bindir)/gringotts
+- chmod u+s $(DESTDIR)$(bindir)/gringotts
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
+--- 481,486 ----
diff --git a/gringotts.install b/gringotts.install
new file mode 100644
index 000000000000..1a872fcf377d
--- /dev/null
+++ b/gringotts.install
@@ -0,0 +1,19 @@
+# arg 1: the new package version
+post_install() {
+cat <<EOF
+ >> To make gringotts work, the soft- and hard-memory limits need to be raised. Please read '/usr/share/doc/gringotts/README' for detailed information.
+EOF
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install $1
+}
+
+# arg 1: the old package version
+post_remove() {
+cat <<EOF
+ >> Check your '/etc/security/limits.conf' file for any changes made for the gringotts package. If you will not use this software in the future, those changes can be deleted.
+EOF
+}