summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-28 20:30:33 +0300
committerDimitris Kiziridis2020-07-28 20:30:33 +0300
commit60425ba5d98d4dbfef98f4e7cc09ef076994227a (patch)
treeacadc7f8021e63c243f14cd028089a7e36e07248
downloadaur-60425ba5d98d4dbfef98f4e7cc09ef076994227a.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a850909b8ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = grinplusplus-bin
+ pkgdesc = A C++ Grin Node & Wallet For Linux
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://grinplusplus.github.io
+ arch = x86_64
+ license = MIT
+ makedepends = gendesk
+ depends = gtk3
+ depends = libxss
+ depends = nss
+ depends = nodejs
+ provides = grinplusplus
+ conflicts = grinplusplus
+ source = grinplusplus-1.1.0.deb::https://github.com/GrinPlusPlus/GrinPlusPlus/releases/download/v1.1.0/GrinPlusPlus.1.1.0.deb
+ source = LICENSE::https://github.com/GrinPlusPlus/GrinPlusPlus/raw/master/LICENSE
+ sha256sums = f799f30b62bb85c66d391dad06648a222b6ebba48e1f6e0c05b846c268777ab3
+ sha256sums = a5e9383c3cb97aa3034e5e4bf1c94a71db0c59b3a7ec1fbf198232fb9dcc5e53
+
+pkgname = grinplusplus-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b01dfd4b98ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=grinplusplus-bin
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='A C++ Grin Node & Wallet For Linux'
+arch=('x86_64')
+url="https://grinplusplus.github.io"
+license=('MIT')
+provides=('grinplusplus')
+conflicts=('grinplusplus')
+depends=('gtk3'
+ 'libxss'
+ 'nss'
+ 'nodejs')
+makedepends=('gendesk')
+source=("${pkgname%-bin}-${pkgver}.deb::https://github.com/GrinPlusPlus/GrinPlusPlus/releases/download/v${pkgver}/GrinPlusPlus.${pkgver}.deb"
+ 'LICENSE::https://github.com/GrinPlusPlus/GrinPlusPlus/raw/master/LICENSE')
+sha256sums=('f799f30b62bb85c66d391dad06648a222b6ebba48e1f6e0c05b846c268777ab3'
+ 'a5e9383c3cb97aa3034e5e4bf1c94a71db0c59b3a7ec1fbf198232fb9dcc5e53')
+
+package() {
+ tar xvf data.tar.xz -C "${pkgdir}"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file