summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2022-03-16 09:27:24 +0100
committerFrederic Bezies2022-03-16 09:27:24 +0100
commitf858a7f37eac67e15936fcc5153007b6ab5dee28 (patch)
treee2f27acc8c60c22309edb97b25b76cec747e4786
parent96c5aced81e9c1e3e29162454547b6578e8360ef (diff)
downloadaur-f858a7f37eac67e15936fcc5153007b6ab5dee28.tar.gz
March, 16th 2022 update
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2294421e7a3f..1d1c177b5549 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grisbi-git
pkgdesc = Personal financial management program - Development version
- pkgver = 2.0.5.r256.gfcdad7609
+ pkgver = 2.0.5.r270.g995c53e71
pkgrel = 1
epoch = 1
url = http://www.grisbi.org
@@ -14,7 +14,7 @@ pkgbase = grisbi-git
provides = grisbi
conflicts = grisbi
replaces = grisbi
- source = git://github.com/grisbi/grisbi.git
+ source = grisbi-git::git+https://github.com/grisbi/grisbi.git
sha256sums = SKIP
pkgname = grisbi-git
diff --git a/PKGBUILD b/PKGBUILD
index 9736033656cb..fe626752b104 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
#Contributor: Maƫl Leclair <mael.leclair@gmail.com>
pkgname=grisbi-git
_pkgname=grisbi
-pkgver=2.0.5.r256.gfcdad7609
+pkgver=2.0.5.r270.g995c53e71
pkgrel=1
epoch=1
pkgdesc="Personal financial management program - Development version"
@@ -15,22 +15,22 @@ makedepends=('git' 'intltool' 'libgsf')
provides=('grisbi')
conflicts=('grisbi')
replaces=('grisbi')
-source=(git://github.com/grisbi/grisbi.git)
+source=("$pkgname"::'git+https://github.com/grisbi/grisbi.git')
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "$pkgname"
git describe --long --tags | sed 's/upstream_version_//;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
}
build() {
- cd "$_pkgname"
+ cd "$pkgname"
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd "$_pkgname"
+ cd "$pkgname"
make DESTDIR="$pkgdir/" install
}