summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago Perrotta2015-06-28 01:26:31 -0300
committerThiago Perrotta2015-06-28 01:27:10 -0300
commit961da0595491e3b2b009361526176b6348943096 (patch)
tree660e34ea5f41a70f1df823955f35c0945a9fc66a
downloadaur-961da0595491e3b2b009361526176b6348943096.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
-rw-r--r--grml-iso.install4
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26db0d4f5cf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = grml-iso
+ pkgdesc = add the grml ISO image to the grub2 boot menu
+ pkgver = 2014.11
+ pkgrel = 1
+ url = http://wiki.grml.org/doku.php?id=rescueboot
+ install = grml-iso.install
+ arch = any
+ license = GPL
+ depends = grub
+ depends = grml-rescueboot>=0.4.5
+ noextract = grml64-full_2014.11.iso
+ source = http://download.grml.org/grml64-full_2014.11.iso
+ md5sums = 51ca23d8335732150f31c021eafc6513
+
+pkgname = grml-iso
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70e758526a0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Thiago Perrotta <perrotta dot thiago at poli dot ufrj dot br>
+
+pkgname=grml-iso
+pkgver=2014.11
+_isover="64-full_$pkgver"
+pkgrel=1
+pkgdesc="add the grml ISO image to the grub2 boot menu"
+url="http://wiki.grml.org/doku.php?id=rescueboot"
+arch=('any')
+license=('GPL')
+depends=('grub' 'grml-rescueboot>=0.4.5')
+install="${pkgname}.install"
+source=("http://download.grml.org/grml${_isover}.iso")
+md5sums=('51ca23d8335732150f31c021eafc6513')
+noextract=(grml${_isover}.iso)
+
+package() {
+ install -Dm644 ${srcdir}/grml${_isover}.iso ${pkgdir}/opt/grml/grml${_isover}.iso
+}
diff --git a/grml-iso.install b/grml-iso.install
new file mode 100644
index 000000000000..c6694ff189b1
--- /dev/null
+++ b/grml-iso.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Don't forget to change ISO_LOCATION on /etc/default/grml-rescueboot"
+ echo 'to "/opt/grml/"'
+}