summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Manske2022-03-18 22:48:07 +0100
committerTobias Manske2022-03-18 22:49:16 +0100
commit749ca0c76d1b0c0697d47e4df6b8950c8ac4d3e1 (patch)
tree1d1da979723cef2af5698ee4c1d4c8c0775c796b
downloadaur-749ca0c76d1b0c0697d47e4df6b8950c8ac4d3e1.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD35
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2fc0b78006c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = grobi-rotate-git
+ pkgdesc = grobi automates applying xrandr profiles when outputs change. This version supports rotation specifiers
+ pkgver = r137.0619061
+ pkgrel = 1
+ url = https://github.com/rad4day/grobi
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = go>=1.4
+ depends = glibc
+ provides = grobi
+ conflicts = grobi
+ conflicts = grobi-git
+ options = !strip
+ source = grobi-rotate-git::git+https://github.com/rad4day/grobi
+ md5sums = SKIP
+
+pkgname = grobi-rotate-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..08f2c9a9278b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+grobi-rotate-git/
+*.pkg.tar.zst
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6016c89f6ef8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Tobias Manske <aur at rad4day dot de>
+options=(!strip)
+pkgname=grobi-rotate-git
+pkgver=r137.0619061
+pkgrel=1
+pkgdesc="grobi automates applying xrandr profiles when outputs change. This version supports rotation specifiers"
+arch=('i686' 'x86_64')
+url="https://github.com/rad4day/grobi"
+license=('BSD')
+depends=('glibc')
+makedepends=('git' 'go>=1.4')
+provides=('grobi')
+conflicts=('grobi' 'grobi-git')
+source=("${pkgname}::git+https://github.com/rad4day/grobi")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)";
+}
+
+build() {
+ cd "$pkgname"
+ go build
+}
+
+package() {
+ install -Dm755 "$pkgname/grobi" "$pkgdir/usr/bin/grobi"
+ install -Dm644 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$pkgname/README.md" "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm644 "$pkgname/doc/grobi.service" "$pkgdir/usr/lib/systemd/user/grobi.service"
+ install -Dm644 "$pkgname/contrib/grobi.bash" "$pkgdir/usr/share/bash-completion/completions/grobi"
+}
+
+# vim:set ts=2 sw=2 et: