summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstarsareintherose2021-12-22 19:59:56 +0000
committerstarsareintherose2021-12-22 19:59:56 +0000
commitb78774fca96fd75f5ebe95d2b45cc2ab421ade40 (patch)
treedf41210c97c08ecb118d7adfe5e9533603ba6ac6
downloadaur-b78774fca96fd75f5ebe95d2b45cc2ab421ade40.tar.gz
int
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55fdefb6ad87
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = grobid
+ pkgdesc = A machine learning software for extracting information from scholarly documents
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://github.com/kermitt2/grobid
+ arch = any
+ license = Apache
+ depends = java-runtime<=11
+ depends = archlinux-java-run
+ provides = grobid
+ conflicts = grobid-git
+ source = https://github.com/kermitt2/grobid/archive/0.7.0.zip
+ sha256sums = 31c48f63d013e7be6731cbc3fa5c872af82d9c9b871ed422bbc5d9fca512297a
+
+pkgname = grobid
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd95282e4ffe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Malacology <guoyizhang at malacology dot com>
+# Contributor: Malacology <guoyizhang at malacology dot com>
+
+pkgname=grobid
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A machine learning software for extracting information from scholarly documents"
+arch=('any')
+url="https://github.com/kermitt2/grobid"
+conflicts=('grobid-git')
+provides=('grobid')
+license=('Apache')
+depends=(
+ 'java-runtime<=11'
+ 'archlinux-java-run'
+)
+source=("https://github.com/kermitt2/grobid/archive/$pkgver.zip")
+sha256sums=('31c48f63d013e7be6731cbc3fa5c872af82d9c9b871ed422bbc5d9fca512297a')
+prepare(){
+ cd $srcdir
+ mkdir build
+}
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ chmod +x gradlew
+ ./gradlew --no-daemon -Dmaven.repo.local="${srcdir}/build" clean install
+
+}
+
+package(){
+ install -dDm755 "$pkgdir"/usr/{bin,share/$pkgname}
+ cp -r $srcdir/build/org/$pkgname/* $pkgdir/usr/share/$pkgname
+
+}