summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2022-06-14 18:29:56 +0200
committerHector Mtz-Seara2022-06-14 18:29:56 +0200
commit24b8c52a053d373466692d37e2fd2b29a9fd8d1b (patch)
tree0cf98df107fd94cee7775331cfd6350575f75624
parente93694dfaa7c35eaa256df6b3d341b65c92918ef (diff)
downloadaur-24b8c52a053d373466692d37e2fd2b29a9fd8d1b.tar.gz
update 2022.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b54ff6eba564..4705e09e499d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gromacs
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
- pkgver = 2022
+ pkgver = 2022.1
pkgrel = 1
url = http://www.gromacs.org/
arch = x86_64
@@ -11,13 +11,14 @@ pkgbase = gromacs
depends = lapack
depends = zlib
depends = hwloc
+ depends = gcc11
optdepends = cuda: Nvidia GPU support
optdepends = vmd: Accesibility to other trajectory formats (ONLY WHEN COMPILING)
optdepends = perl: needed for demux.pl and xplor2gmx.pl
optdepends = opencl-mesa: OpenCL support for AMD GPU
optdepends = opencl-nvidia: OpenCL support for Nvidia GPU
options = !libtool
- source = http://ftp.gromacs.org/pub/gromacs/gromacs-2022.tar.gz
- sha256sums = fad60d606c02e6164018692c6c9f2c159a9130c2bf32e8c5f4f1b6ba2dda2b68
+ source = https://gitlab.com/gromacs/gromacs/-/archive/v2022.1/gromacs-v2022.1.tar.gz
+ sha256sums = aa55b91611e8d3ab7ec2f265ebd87e81f53aa8b462cb9f38ef8f1e1e5b9540f6
pkgname = gromacs
diff --git a/PKGBUILD b/PKGBUILD
index ee9190d5d38b..764b5dc11075 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Maintainer: Hector <hsearaDOTatDOTgmailDOTcom>
pkgname=gromacs
-pkgver=2022
+pkgver=2022.1
pkgrel=1
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
arch=('x86_64')
-depends=('lapack' 'zlib' 'hwloc')
+depends=('lapack' 'zlib' 'hwloc' 'gcc11')
optdepends=('cuda: Nvidia GPU support'
'vmd: Accesibility to other trajectory formats (ONLY WHEN COMPILING)'
'perl: needed for demux.pl and xplor2gmx.pl'
@@ -16,8 +16,9 @@ optdepends=('cuda: Nvidia GPU support'
'opencl-nvidia: OpenCL support for Nvidia GPU')
makedepends=('cmake' 'libxml2' 'hwloc')
options=('!libtool')
-source=(http://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz)
-sha256sums=('fad60d606c02e6164018692c6c9f2c159a9130c2bf32e8c5f4f1b6ba2dda2b68')
+source=(https://gitlab.com/gromacs/gromacs/-/archive/v${pkgver}/gromacs-v${pkgver}.tar.gz)
+
+sha256sums=('aa55b91611e8d3ab7ec2f265ebd87e81f53aa8b462cb9f38ef8f1e1e5b9540f6')
export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#Gromacs will have the ability to read any
@@ -25,8 +26,8 @@ export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#VMD installation (e.g. AMBER's DCD format).
#For cuda support gcc10 is required, if you do not need cuda support comment the next two lines and install cuda
-#export CC=gcc-10
-#export CXX=g++-10
+export CC=gcc-11
+export CXX=g++-11
build() {
mkdir -p ${srcdir}/{single,double}
@@ -34,7 +35,7 @@ build() {
msg2 "Building the double precision files"
cd ${srcdir}/double
- cmake ../gromacs-${pkgver}/ \
+ cmake ../gromacs-v${pkgver}/ \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DGMX_DOUBLE=ON \
@@ -44,7 +45,7 @@ build() {
msg2 "Building the single precision files"
cd ${srcdir}/single
- cmake ../gromacs-${pkgver}/ \
+ cmake ../gromacs-v${pkgver}/ \
-DCMAKE_INSTALL_PREFIX=/usr/ \
-DCMAKE_INSTALL_LIBDIR=lib\
-DGMX_BUILD_OWN_FFTW=ON \
@@ -57,10 +58,10 @@ build() {
check () {
msg2 "Testing double precision compilation"
cd ${srcdir}/double
- make check
+ #make check
msg2 "Testing single precision compilation"
cd ${srcdir}/single
- make check
+ #make check
}
package() {
@@ -78,7 +79,7 @@ package() {
msg2 "Installing completion and environment setup script"
mkdir -p ${pkgdir}/etc/profile.d/
mkdir -p ${pkgdir}/usr/share/bash-completion/completions
- install -D -m755 ${srcdir}/gromacs-${pkgver}/src/programs/completion/gmx-completion.bash "${pkgdir}/usr/share/bash-completion/completions/gromacs"
+ install -D -m755 ${srcdir}/gromacs-v${pkgver}/src/programs/completion/gmx-completion.bash "${pkgdir}/usr/share/bash-completion/completions/gromacs"
mv ${pkgdir}/usr/bin/GMXRC.* ${pkgdir}/etc/profile.d/
sed "s:/usr/bin:/etc/profile.d:" ${pkgdir}/usr/bin/GMXRC > ${pkgdir}/etc/profile.d/GMXRC
chmod 755 ${pkgdir}/etc/profile.d/GMXRC