summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Martinez-Seara2019-06-26 17:38:48 +0200
committerHector Martinez-Seara2019-06-26 17:38:48 +0200
commit7c862df0e053f3e25a43ad6a9708a0bf74d9550f (patch)
tree7ba7a6367bd9b8a331eb7c8955e01209d5102255
parentef90182f97093f8893d532ed013f8e34f16a81c9 (diff)
downloadaur-7c862df0e053f3e25a43ad6a9708a0bf74d9550f.tar.gz
Fixed cuda support (added gcc8 dependency)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d05f729cf405..3db2cd38890c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gromacs
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
pkgver = 2019.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.gromacs.org/
arch = i686
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = gromacs
makedepends = cmake
makedepends = libxml2
makedepends = hwloc
+ makedepends = gcc8
depends = lapack
depends = zlib
depends = hwloc
diff --git a/PKGBUILD b/PKGBUILD
index 5c0c46085132..5e377c1ae103 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gromacs
pkgver=2019.3
-pkgrel=1
+pkgrel=2
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
@@ -14,7 +14,7 @@ optdepends=('cuda: Nvidia GPU support'
'perl: needed for demux.pl and xplor2gmx.pl'
'opencl-mesa: OpenCL support for AMD GPU'
'opencl-nvidia: OpenCL support for Nvidia GPU')
-makedepends=('cmake' 'libxml2' 'hwloc')
+makedepends=('cmake' 'libxml2' 'hwloc' 'gcc8')
options=('!libtool')
source=(http://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz)
sha1sums=('c4a639024d1a1e2b9cdaea180610a56c1596dcaa')
@@ -24,6 +24,10 @@ export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#trajectory file format that can be read by
#VMD installation (e.g. AMBER's DCD format).
+#For cuda8 support gcc8 is required, if you do not need cuda support comment the next two lines
+export CC=gcc-8
+export CXX=g++-8
+
build() {
mkdir -p ${srcdir}/{single,double}