summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Martinez-Seara2024-05-06 14:49:03 +0200
committerHector Martinez-Seara2024-05-06 14:49:03 +0200
commita150867d739584b967009da8bdf68f637765a94e (patch)
treee54b119c4c36f3126392e35f0a887e74ba3660ef
parentc6da449cfeac5e06b50e66be9d18bb5ec3e599cc (diff)
downloadaur-a150867d739584b967009da8bdf68f637765a94e.tar.gz
Updated 2024.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15a30eae3921..bd6051792ab9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gromacs
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
- pkgver = 2023.2
+ pkgver = 2024.1
pkgrel = 1
url = http://www.gromacs.org/
arch = x86_64
@@ -11,13 +11,14 @@ pkgbase = gromacs
depends = lapack
depends = zlib
depends = hwloc
+ depends = gcc12
optdepends = cuda: Nvidia GPU support
optdepends = vmd: Accesibility to other trajectory formats (ONLY WHEN COMPILING)
optdepends = perl: needed for demux.pl and xplor2gmx.pl
optdepends = opencl-mesa: OpenCL support for AMD GPU
optdepends = opencl-nvidia: OpenCL support for Nvidia GPU
options = !libtool
- source = https://gitlab.com/gromacs/gromacs/-/archive/v2023.2/gromacs-v2023.2.tar.gz
- sha256sums = 70a7b9e4cdafb21336213613f9d72228e338770a15548e24917251c32af599c9
+ source = https://gitlab.com/gromacs/gromacs/-/archive/v2024.1/gromacs-v2024.1.tar.gz
+ sha256sums = b215e25ab4b99ab0b037770a3108c0d4a7917311a8345524a4fd5423f91c7e46
pkgname = gromacs
diff --git a/PKGBUILD b/PKGBUILD
index 5bc314f6695b..5e1f6b8821d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Maintainer: Vedran Miletic <vedran AT miletic DOT net>
pkgname=gromacs
-pkgver=2023.2
+pkgver=2024.1
pkgrel=1
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
arch=('x86_64')
-depends=('lapack' 'zlib' 'hwloc')
+depends=('lapack' 'zlib' 'hwloc' 'gcc12')
optdepends=('cuda: Nvidia GPU support'
'vmd: Accesibility to other trajectory formats (ONLY WHEN COMPILING)'
'perl: needed for demux.pl and xplor2gmx.pl'
@@ -19,7 +19,7 @@ makedepends=('cmake' 'libxml2' 'hwloc')
options=('!libtool')
source=(https://gitlab.com/gromacs/gromacs/-/archive/v${pkgver}/gromacs-v${pkgver}.tar.gz)
-sha256sums=('70a7b9e4cdafb21336213613f9d72228e338770a15548e24917251c32af599c9')
+sha256sums=('b215e25ab4b99ab0b037770a3108c0d4a7917311a8345524a4fd5423f91c7e46')
export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#Gromacs will have the ability to read any
@@ -29,8 +29,8 @@ export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
# For CUDA (12+) support, compiling with GCC 12 is required.
# If you not need CUDA support, uncomment the next two lines
# and install cuda and gcc12 packages.
-#export CC=gcc-12
-#export CXX=g++-12
+export CC=gcc-12
+export CXX=g++-12
build() {
mkdir -p ${srcdir}/{single,double}
@@ -52,7 +52,7 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DGMX_BUILD_OWN_FFTW=ON \
-DREGRESSIONTEST_DOWNLOAD=ON \
- #-GMX_GPU=CUDA
+ #-DGMX_GPU=CUDA
# For GPU acceleration support, uncomment the previous line and pick one: OFF, CUDA, OpenCL, SYCL
make
}