summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2016-09-19 13:28:40 +0200
committerHector Mtz-Seara2016-09-19 13:28:40 +0200
commite28c0895b369390350ea7fe42c7bab339720b8be (patch)
tree20a8a92d1f17d57bf7edfb9a77411a122e851ae9
parent6cb6d49492adde9099f1a7b399e8d20ff7df8725 (diff)
downloadaur-e28c0895b369390350ea7fe42c7bab339720b8be.tar.gz
Upadated to gromacs-2016 - Using self compiled fftw
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0767d4c75d06..2621391ef130 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
-# Generated by mksrcinfo v8
-# Tue Feb 16 16:04:01 UTC 2016
pkgbase = gromacs
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
- pkgver = 5.1.2
+ pkgver = 2016
pkgrel = 1
url = http://www.gromacs.org/
arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
- depends = atlas-lapack-base
- depends = fftw
- depends = lesstif
- depends = libxml2
+ depends = blas
+ depends = lapack
+ depends = cblas
+ depends = zlib
+ depends = hwloc
+ depends = libx11
options = !libtool
- source = ftp://ftp.gromacs.org/pub/gromacs/gromacs-5.1.2.tar.gz
- sha1sums = 4a9a77711206c8cd0e1f4dd31f2edc569589e9dc
+ source = ftp://ftp.gromacs.org/pub/gromacs/gromacs-2016.tar.gz
+ sha1sums = 2dcbb922acce6df74f0b381f80989a4da63cd0ce
pkgname = gromacs
diff --git a/PKGBUILD b/PKGBUILD
index 3c78472f78ce..a72208951fba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,17 +5,23 @@
# Contributor: Ricardo <rikardo.horo@gmail.com>
pkgname=gromacs
-pkgver=5.1.2
+pkgver=2016
pkgrel=1
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
arch=('i686' 'x86_64')
-depends=('atlas-lapack-base' 'fftw' 'lesstif' 'libxml2')
+depends=('blas' 'lapack' 'cblas' 'zlib' 'hwloc' 'libx11')
makedepends=('cmake')
options=('!libtool')
source=(ftp://ftp.gromacs.org/pub/gromacs/${pkgname}-${pkgver}.tar.gz)
-sha1sums=('4a9a77711206c8cd0e1f4dd31f2edc569589e9dc')
+sha1sums=('2dcbb922acce6df74f0b381f80989a4da63cd0ce')
+
+#With gcc5 currently there are less errors in the tests
+# also the compilation is possible in cuda capable machines
+export CC=gcc-5
+export CXX=g++-5
+
build() {
mkdir -p ${srcdir}/{single,double}
@@ -34,6 +40,7 @@ build() {
-DGMX_X11=ON \
-DCMAKE_INSTALL_LIBDIR=lib \
-DGMX_DOUBLE=ON \
+ -DGMX_BUILD_OWN_FFTW=ON \
-DREGRESSIONTEST_DOWNLOAD=ON \
-DGMX_LIBS_SUFFIX=_d
make
@@ -44,6 +51,7 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr/ \
-DBUILD_SHARED_LIBS=ON \
-DGMX_X11=ON \
+ -DGMX_BUILD_OWN_FFTW=ON \
-DREGRESSIONTEST_DOWNLOAD=ON \
-DCMAKE_INSTALL_LIBDIR=lib
make