summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Martinez-Seara2019-01-27 17:41:54 +0100
committerHector Martinez-Seara2019-01-27 17:41:54 +0100
commit1920942a1b326bd91bd80009c362e82ee721322a (patch)
tree36487176dc63e6f49148be5cd919320e96208357
parent3a6cf3a6c89e427731065c59f31c34f584ec5b80 (diff)
downloadaur-1920942a1b326bd91bd80009c362e82ee721322a.tar.gz
Compilation using GCC7 that is compatible with cuda10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55780ac8bec8..fa1035dc209d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gromacs-2016-complete
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
pkgver = 2016.5
- pkgrel = 1
+ pkgrel = 2
url = http://www.gromacs.org/
arch = i686
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = gromacs-2016-complete
makedepends = cmake
makedepends = libxml2
makedepends = hwloc
- makedepends = gcc6
+ makedepends = gcc7
depends = lapack
depends = zlib
depends = libx11
diff --git a/PKGBUILD b/PKGBUILD
index fd8605fe94d3..4b44fb320696 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gromacs-2016-complete
pkgver=2016.5
-pkgrel=1
+pkgrel=2
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
@@ -14,17 +14,17 @@ optdepends=('cuda: Nvidia GPU support'
'perl: needed for demux.pl and xplor2gmx.pl'
'opencl-mesa: OpenCL support for AMD GPU'
'opencl-nvidia: OpenCL support for Nvidia GPU')
-makedepends=('cmake' 'libxml2' 'hwloc' 'gcc6')
+makedepends=('cmake' 'libxml2' 'hwloc' 'gcc7')
options=('!libtool')
source=(http://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
GMXRC.bash.cmakein.patch)
sha1sums=('8c24c9c52213502e927c13d69cdc4296415a4136'
'014b2cbfa13db9b495c88f653805c330747117dc')
-#With gcc6 currently there are less errors in the tests
+#With gcc7 currently there are less errors in the tests
# also the compilation is possible in CUDA capable machines
-export CC=gcc-6
-export CXX=g++-6
+export CC=gcc-7
+export CXX=g++-7
export CFLAGS="-march=native -O2 -pipe -fstack-protector-strong"
export CXXFLAGS="${CFLAGS}"