summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Martinez-Seara2019-04-02 14:33:40 +0200
committerHector Martinez-Seara2019-04-02 14:33:40 +0200
commit3f8909029878c12f9d12277846dd22b351015a22 (patch)
tree662d3d83fbcd8513d38442c9dab77cc559fa8548
parent2c0c72a41894639eeacd8cd2acafd7c16353d80a (diff)
downloadaur-3f8909029878c12f9d12277846dd22b351015a22.tar.gz
CUDA now accepts default system gcc
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 3 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6201b97f2d69..b3b92a8b1b03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = gromacs-2016-complete
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
pkgver = 2016.6
- pkgrel = 1
+ pkgrel = 2
url = http://www.gromacs.org/
- arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index ef91858f9844..d281f6cf7c29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
pkgname=gromacs-2016-complete
pkgver=2016.6
-pkgrel=1
+pkgrel=2
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
-arch=('i686' 'x86_64')
+arch=('x86_64')
depends=('lapack' 'zlib' 'libx11')
optdepends=('cuda: Nvidia GPU support'
'openmotif: needed for gmx view'
@@ -20,13 +20,6 @@ source=(http://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
sha1sums=('1a9643eea0f147f47c28b7cb9a2662b5585fe41d'
'014b2cbfa13db9b495c88f653805c330747117dc')
-#With gcc7 currently there are less errors in the tests
-# also the compilation is possible in CUDA capable machines
-export CC=gcc-7
-export CXX=g++-7
-export CFLAGS="-march=native -O2 -pipe -fstack-protector-strong"
-export CXXFLAGS="${CFLAGS}"
-
export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#Gromacs will have the ability to read any
#trajectory file format that can be read by
@@ -49,7 +42,6 @@ build() {
-DGMX_DOUBLE=ON \
-DGMX_BUILD_OWN_FFTW=ON \
-DREGRESSIONTEST_DOWNLOAD=ON
- # -DGMX_LIBS_SUFFIX=_d
make
msg2 "Building the single precision files"