summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2021-09-01 12:28:59 +0200
committerHector Mtz-Seara2021-09-01 12:28:59 +0200
commitb0d8791417573e17186c2271d710f899e5a9f2cc (patch)
treefa67fa906091f47876e2d60d1ff05c2417dd661a
parent9fa68e0ead7ae9a1c2cbe6a0a73a407e7f8b695e (diff)
downloadaur-b0d8791417573e17186c2271d710f899e5a9f2cc.tar.gz
Updated to 2020.6
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6cd87f7b576..e8f8172e93e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gromacs-2020-complete
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
- pkgver = 2020.5
+ pkgver = 2020.6
pkgrel = 1
url = http://www.gromacs.org/
arch = x86_64
@@ -17,8 +17,7 @@ pkgbase = gromacs-2020-complete
optdepends = opencl-mesa: OpenCL support for AMD GPU
optdepends = opencl-nvidia: OpenCL support for Nvidia GPU
options = !libtool
- source = http://ftp.gromacs.org/pub/gromacs/gromacs-2020.5.tar.gz
- sha256sums = 7b6aff647f7c8ee1bf12204d02cef7c55f44402a73195bd5f42cf11850616478
+ source = http://ftp.gromacs.org/pub/gromacs/gromacs-2020.6.tar.gz
+ sha256sums = d8bbe57ed3c9925a8cb99ecfe39e217f930bed47d5268a9e42b33da544bdb2ee
pkgname = gromacs-2020-complete
-
diff --git a/PKGBUILD b/PKGBUILD
index 2df50ec5d7b3..8d51e84173ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Hector <hsearaDOTatDOTgmailDOTcom>
pkgname=gromacs-2020-complete
-pkgver=2020.5
+pkgver=2020.6
pkgrel=1
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
@@ -17,13 +17,18 @@ optdepends=('cuda: Nvidia GPU support'
makedepends=('cmake' 'libxml2' 'hwloc')
options=('!libtool')
source=(http://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz)
-sha256sums=('7b6aff647f7c8ee1bf12204d02cef7c55f44402a73195bd5f42cf11850616478')
+sha256sums=('d8bbe57ed3c9925a8cb99ecfe39e217f930bed47d5268a9e42b33da544bdb2ee')
export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#Gromacs will have the ability to read any
#trajectory file format that can be read by
#VMD installation (e.g. AMBER's DCD format).
+#For cuda support gcc10 is required, if you do not need cuda support comment the next two lines and install cuda
+export CC=gcc-10
+export CXX=g++-10
+
+
build() {
mkdir -p ${srcdir}/{single,double}