summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2015-07-15 17:15:57 +0300
committerHector Mtz-Seara2015-07-15 17:15:57 +0300
commitba7a7ea212e49dfa3243f94831c420faeaa039a0 (patch)
tree059eee8d031a4d08e227e4a5d7bd5853fd000c69
downloadaur-ba7a7ea212e49dfa3243f94831c420faeaa039a0.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--GMXRC.bash.cmakein.patch14
-rw-r--r--PKGBUILD77
3 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51a1b71749c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gromacs-4.6-complete
+ pkgdesc = GROMACS is a versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
+ pkgver = 4.6.7
+ pkgrel = 3
+ url = http://www.gromacs.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fftw
+ depends = lesstif
+ depends = perl
+ depends = libxml2
+ depends = libsm
+ depends = libx11
+ depends = doxygen
+ options = !libtool
+ source = ftp://ftp.gromacs.org/pub/gromacs/gromacs-4.6.7.tar.gz
+ source = GMXRC.bash.cmakein.patch
+ sha1sums = 923ed238963027201c329ff34dbef414fe68f4e9
+ sha1sums = 014b2cbfa13db9b495c88f653805c330747117dc
+
+pkgname = gromacs-4.6-complete
+
diff --git a/GMXRC.bash.cmakein.patch b/GMXRC.bash.cmakein.patch
new file mode 100644
index 000000000000..f0408d787a2e
--- /dev/null
+++ b/GMXRC.bash.cmakein.patch
@@ -0,0 +1,14 @@
+--- GMXRC.bash.cmakein 2013-11-08 13:09:33.000000000 +0200
++++ GMXRC.bash.cmakein.patch 2015-02-20 12:48:10.770670309 +0200
+@@ -4,6 +4,11 @@
+ # This is not 100% necessary, but very useful when we
+ # repeatedly switch between gmx versions in a shell.
+
++#Patch to avoid problems when gromacs is installed using /usr/ as root
++if [ "$GMXLDLIB" == "/usr/lib" ]; then export GMXLDLIB=""; fi
++if [ "$GMXBIN" == "/usr/bin" ]; then export GMXBIN=""; fi
++if [ "$GMXMAN" == "/usr/share/man" ]; then export GMXMAN=""; fi
++
+ # First remove gromacs part of ld_library_path
+ tmppath=""
+ for i in `echo $LD_LIBRARY_PATH | sed "s/:/ /g"`; do
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c21d7939bdc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Mantainer: Hector <hsearaDOTatDOTgmailDOTcom>
+
+pkgname=gromacs-4.6-complete
+pkgver=4.6.7
+pkgrel=3
+pkgdesc='GROMACS is a versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
+url='http://www.gromacs.org/'
+license=("GPL")
+arch=('i686' 'x86_64')
+depends=('fftw' 'lesstif' 'perl' 'libxml2' 'libsm' 'libx11' 'doxygen')
+options=('!libtool')
+source=(ftp://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
+ GMXRC.bash.cmakein.patch)
+sha1sums=('923ed238963027201c329ff34dbef414fe68f4e9'
+ '014b2cbfa13db9b495c88f653805c330747117dc')
+
+
+export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
+ #Gromacs will have the ability to read any
+ #trajectory file format that can be read by
+ #VMD installation (e.g. AMBER's DCD format).
+
+prepare() {
+cd ${srcdir}/gromacs-${pkgver}/scripts/
+ls
+patch -p0 -i ${srcdir}/GMXRC.bash.cmakein.patch
+}
+
+build() {
+
+ mkdir -p ${srcdir}/{single,double}
+
+ msg2 "Building the single precision files"
+ cd ${srcdir}/single
+ cmake ../gromacs-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr/local/gromacs/gromacs-${pkgver} \
+ -DBUILD_SHARED_LIBS=ON \
+ -DGMX_DEFAULT_SUFFIX=ON \
+ -DREGRESSIONTEST_DOWNLOAD=ON \
+ -DGMX_OPENMP=ON
+ make
+
+ msg2 "Building the double precision files"
+ cd ${srcdir}/double
+ cmake ../gromacs-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr/local/gromacs/gromacs-${pkgver} \
+ -DBUILD_SHARED_LIBS=ON \
+ -DGMX_DEFAULT_SUFFIX=ON \
+ -DREGRESSIONTEST_DOWNLOAD=ON \
+ -DGMX_DOUBLE=ON \
+ -DGMX_OPENMP=ON
+ make
+}
+
+check () {
+ cd ${srcdir}/single
+ make test
+ cd ${srcdir}/double
+ make test
+}
+
+package() {
+ msg2 "Making the single precision executables"
+ cd ${srcdir}/single
+ make DESTDIR=${pkgdir} install
+
+ msg2 "Making the double precision executables"
+ cd ${srcdir}/double
+ make DESTDIR=${pkgdir} install
+
+ msg2 "Installing Sources"
+ cp -r ${srcdir}/gromacs-${pkgver}/src ${pkgdir}/usr/local/gromacs/gromacs-${pkgver}/
+ cd ${pkgdir}/usr/local/gromacs/gromacs-${pkgver}/src
+ find . -type f -exec chmod 0644 {} \;
+ find . -type d -exec chmod 0755 {} \;
+}
+