summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2017-09-06 10:26:00 +0200
committerHector Mtz-Seara2017-09-06 10:26:00 +0200
commit85e8ba0ede2c328794071ec1224b7dc0fe3ce53e (patch)
tree4c20c90a5df219dcb51b1d16fcf23c558d894930
parentadaf2421f7ed50e427651442d4a5573256b3e267 (diff)
downloadaur-85e8ba0ede2c328794071ec1224b7dc0fe3ce53e.tar.gz
Refined dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57e16a9f9c81..786494adaeb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = gromacs-5.0-complete
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
pkgver = 5.0.7
- pkgrel = 5
+ pkgrel = 6
url = http://www.gromacs.org/
arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
makedepends = libxml2
- depends = gcc5
+ makedepends = hwloc
+ makedepends = gcc5
+ depends = lapack
+ depends = zlib
+ depends = libx11
optdepends = cuda: Nvidia GPU support
optdepends = openmotif: needed for gmx view
- optdepends = libx11: needed for gmx view
+ optdepends = perl: needed for demux.pl and xplor2gmx.pl
options = !libtool
source = ftp://ftp.gromacs.org/pub/gromacs/gromacs-5.0.7.tar.gz
source = GMXRC.bash.cmakein.patch
diff --git a/PKGBUILD b/PKGBUILD
index e3a9f7c31d34..815234440683 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=gromacs-5.0-complete
pkgver=5.0.7
-pkgrel=5
+pkgrel=6
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
arch=('i686' 'x86_64')
-depends=('gcc5')
+depends=('lapack' 'zlib' 'libx11')
optdepends=('cuda: Nvidia GPU support'
'openmotif: needed for gmx view'
- 'libx11: needed for gmx view')
-makedepends=('cmake' 'libxml2')
+ 'perl: needed for demux.pl and xplor2gmx.pl')
+makedepends=('cmake' 'libxml2' 'hwloc' 'gcc5')
options=('!libtool')
source=(ftp://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
GMXRC.bash.cmakein.patch)
@@ -53,6 +53,7 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DGMX_DOUBLE=ON \
-DREGRESSIONTEST_DOWNLOAD=ON \
+ -DGMX_BUILD_OWN_FFTW=ON \
-DGMX_LIBS_SUFFIX=_d
make
@@ -63,6 +64,7 @@ build() {
-DBUILD_SHARED_LIBS=ON \
-DGMX_X11=ON \
-DREGRESSIONTEST_DOWNLOAD=ON \
+ -DGMX_BUILD_OWN_FFTW=ON \
-DCMAKE_CXX_FLAGS="-std=c++11" \
-DCMAKE_INSTALL_LIBDIR=lib
make