summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2017-09-05 09:37:53 +0200
committerHector Mtz-Seara2017-09-05 09:37:53 +0200
commitadaf2421f7ed50e427651442d4a5573256b3e267 (patch)
tree35a2f7378a1c97b98a14e47948bf1f878e714184
parenteea5b1928b58b36974057eb5ddafe1e8a7b022de (diff)
downloadaur-adaf2421f7ed50e427651442d4a5573256b3e267.tar.gz
Refined dependencies and added CMAKE_CXX_FLAGS=-std=c++11
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61f661238411..57e16a9f9c81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = gromacs-5.0-complete
pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.
pkgver = 5.0.7
- pkgrel = 4
+ pkgrel = 5
url = http://www.gromacs.org/
arch = i686
arch = x86_64
license = LGPL
makedepends = cmake
- depends = fftw
- depends = perl
- depends = libxml2
- depends = libsm
+ makedepends = libxml2
+ depends = gcc5
+ optdepends = cuda: Nvidia GPU support
+ optdepends = openmotif: needed for gmx view
+ optdepends = libx11: needed for gmx view
options = !libtool
source = ftp://ftp.gromacs.org/pub/gromacs/gromacs-5.0.7.tar.gz
source = GMXRC.bash.cmakein.patch
diff --git a/PKGBUILD b/PKGBUILD
index f115a2387d0c..e3a9f7c31d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,16 @@
pkgname=gromacs-5.0-complete
pkgver=5.0.7
-pkgrel=4
+pkgrel=5
pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles.'
url='http://www.gromacs.org/'
license=("LGPL")
arch=('i686' 'x86_64')
-depends=('fftw' 'perl' 'libxml2' 'libsm')
-makedepends=('cmake')
+depends=('gcc5')
+optdepends=('cuda: Nvidia GPU support'
+ 'openmotif: needed for gmx view'
+ 'libx11: needed for gmx view')
+makedepends=('cmake' 'libxml2')
options=('!libtool')
source=(ftp://ftp.gromacs.org/pub/gromacs/gromacs-${pkgver}.tar.gz
GMXRC.bash.cmakein.patch)
@@ -20,6 +23,10 @@ export VMDDIR=/usr/lib/vmd/ #If vmd is available at compilation time
#Gromacs will have the ability to read any
#trajectory file format that can be read by
#VMD installation (e.g. AMBER's DCD format).
+#With gcc5 currently there are less errors in the tests
+# also the compilation is possible in cuda capable machines
+export CC=gcc-5
+export CXX=g++-5
prepare() {
cd ${srcdir}/gromacs-${pkgver}/scripts/
@@ -56,6 +63,7 @@ build() {
-DBUILD_SHARED_LIBS=ON \
-DGMX_X11=ON \
-DREGRESSIONTEST_DOWNLOAD=ON \
+ -DCMAKE_CXX_FLAGS="-std=c++11" \
-DCMAKE_INSTALL_LIBDIR=lib
make
}