summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Barnett2015-06-16 22:13:21 -0500
committerJames Barnett2015-06-16 22:13:21 -0500
commitef27add0a4d2b61d39f8afa37bdaaff9fbd99507 (patch)
tree11b08bc2fc61714618a7eac1bd4eca27b0143f24
downloadaur-ef27add0a4d2b61d39f8afa37bdaaff9fbd99507.tar.gz
intial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d61a27e4261
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gromacs-git
+ pkgdesc = A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles. Development branch.
+ pkgver = 5.1.beta1.r121.gabc4a07
+ pkgrel = 1
+ url = http://www.gromacs.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ depends = fftw-bettersimd
+ optdepends = openmpi: needed for parallelization across nodes
+ optdepends = lapack: normal modes and matrix manipulation
+ optdepends = boost-libs: better implementation support for smart pointers and exception handling
+ optdepends = libxml2: required for running test suite
+ optdepends = libx11: needed for gmx view
+ optdepends = lesstif: needed for gmx view
+ optdepends = vmd: visualization
+ options = !libtool
+ source = git://git.gromacs.org/gromacs.git
+ sha1sums = SKIP
+
+pkgname = gromacs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f30be096dbe9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: James W. Barnett <jbarnet4@tulane.edu>
+pkgname=gromacs-git
+pkgver=5.1.beta1.r121.gabc4a07
+pkgrel=1
+pkgdesc='A versatile package to perform molecular dynamics, i.e. simulate the Newtonian equations of motion for systems with hundreds to millions of particles. Development branch.'
+url='http://www.gromacs.org/'
+license=("LGPL")
+arch=('i686' 'x86_64')
+depends=('fftw-bettersimd')
+makedepends=('cmake')
+optdepends=('openmpi: needed for parallelization across nodes'
+ 'lapack: normal modes and matrix manipulation'
+ 'boost-libs: better implementation support for smart pointers and exception handling'
+ 'libxml2: required for running test suite'
+ 'libx11: needed for gmx view'
+ 'lesstif: needed for gmx view'
+ 'vmd: visualization')
+options=('!libtool')
+source=(git://git.gromacs.org/gromacs.git)
+sha1sums=('SKIP')
+
+build() {
+ mkdir -p ${srcdir}/gromacs/build
+ cd ${srcdir}/gromacs/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DGMX_DEFAULT_SUFFIX=OFF \
+ -DGMX_BINARY_SUFFIX=_dev \
+ -DGMX_LIBS_SUFFIX=_dev \
+ -DREGRESSIONTEST_DOWNLOAD=ON
+ make
+}
+
+pkgver() {
+ cd ${srcdir}/gromacs
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd ${srcdir}/gromacs/build
+ make check
+}
+
+package() {
+ cd ${srcdir}/gromacs/build
+ make DESTDIR=${pkgdir} install
+}