summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhawkeye1164772023-10-10 00:50:04 +0200
committerhawkeye1164772023-10-10 00:50:04 +0200
commitce46f8b2d80c55b885a9c16907f627e48a9127b8 (patch)
treeda6e1ac62d631f0c1a001184885fa4dcc71f9708
parenta31ee4022a692bf47fd8e0e2f19ee1669cf09ee4 (diff)
downloadaur-groupsdomainsextractor.tar.gz
Update
-rw-r--r--.SRCINFO28
-rw-r--r--LICENSE.txt17
-rw-r--r--PKGBUILD51
3 files changed, 29 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bf14a54cd85..3018616fe05c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = groupsdomainsextractor
pkgdesc = Find all domains of specific group and copy it to clipboard
- pkgver = 1.2.2
+ pkgver = 1.3.0
pkgrel = 1
- url = https://github.com/PolishFiltersTeam/ScriptsPlayground/blob/master/Readme_GDE.md
+ url = https://github.com/FiltersHeroes/ScriptsPlayground/blob/master/Readme_GDE.md
arch = any
- license = MIT
- makedepends = unzip
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- depends = python-certifi
- depends = python-urllib3
depends = python-beautifulsoup4
depends = python-tldextract
- depends = python-pysimplegui
- depends = python-appdirs
- depends = python-html5lib
- source = https://github.com/PolishFiltersTeam/ScriptsPlayground/releases/download/GDE-1.2.2/GDE.zip
- source = LICENSE.txt
- sha256sums = de399487adc99094dbaf00a22658befbb58b5d17ddcea8d3bc70c4e5de003363
- sha256sums = 84c872a68ddd7b81d71673d560480dcaf0d83a7f694bb6521b2dbcebd2d2c912
+ depends = python-requests
+ depends = python-qtpy
+ depends = qt5-python-bindings
+ depends = python-platformdirs
+ depends = gettext
+ source = https://github.com/FiltersHeroes/ScriptsPlayground/releases/download/GDE-1.3.0/GDE-1.3.0.tar.gz
+ sha256sums = 40ff6372ba05c2d7001c70f3086eb3ec6a16c5c7bcb1a6dfc0ddab5e973486ea
pkgname = groupsdomainsextractor
-
diff --git a/LICENSE.txt b/LICENSE.txt
deleted file mode 100644
index 76c36e272350..000000000000
--- a/LICENSE.txt
+++ /dev/null
@@ -1,17 +0,0 @@
-MIT License
-Copyright (c) 2019 Polish Filters Team
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 5ec2c71d91cf..7fff9a934a76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,28 @@
# Maintainer: hawkeye116477 <hawkeye116477 at gmail.com>
pkgname=groupsdomainsextractor
-pkgver=1.2.2
+_name=GDE
+pkgver=1.3.0
pkgrel=1
pkgdesc="Find all domains of specific group and copy it to clipboard"
-url="https://github.com/PolishFiltersTeam/ScriptsPlayground/blob/master/Readme_GDE.md"
-license=('MIT')
-depends=('python' 'python-certifi' 'python-urllib3' 'python-beautifulsoup4' 'python-tldextract' 'python-pysimplegui' 'python-appdirs' 'python-html5lib')
-makedepends=('unzip')
+url="https://github.com/FiltersHeroes/ScriptsPlayground/blob/master/Readme_GDE.md"
+license=('GPL3')
+depends=('python' 'python-beautifulsoup4' 'python-tldextract' 'python-requests' 'python-qtpy' 'qt5-python-bindings' 'python-platformdirs' 'gettext')
+makedepends=(python-setuptools python-build python-installer python-wheel)
arch=('any')
source=(
- "https://github.com/PolishFiltersTeam/ScriptsPlayground/releases/download/GDE-$pkgver/GDE.zip"
- "LICENSE.txt"
+ "https://github.com/FiltersHeroes/ScriptsPlayground/releases/download/GDE-$pkgver/GDE-$pkgver.tar.gz"
)
-sha256sums=('de399487adc99094dbaf00a22658befbb58b5d17ddcea8d3bc70c4e5de003363'
- '84c872a68ddd7b81d71673d560480dcaf0d83a7f694bb6521b2dbcebd2d2c912')
+sha256sums=('40ff6372ba05c2d7001c70f3086eb3ec6a16c5c7bcb1a6dfc0ddab5e973486ea')
-prepare() {
- mkdir -p "$srcdir"/opt/
- unzip GDE.zip -d "$srcdir"/opt/$pkgname/
- rm -rf "$srcdir"/opt/$pkgname/requirements.txt
+build() {
+ cd "$_name-$pkgver" || exit
+ python -m build --wheel --no-isolation
}
package()
{
- mkdir -p "$pkgdir"/opt/$pkgname/
- cp -R "$srcdir"/opt/* "$pkgdir"/opt/
-
- install -Dm755 /dev/stdin "$pkgdir/usr/bin/GDE" <<END
-#!/bin/bash
-python3 /opt/$pkgname/GDE.py "\$@"
-END
-
- install -Dm755 /dev/stdin "$pkgdir/usr/share/applications/GDE.desktop" <<END
-[Desktop Entry]
-Version=1.0
-Name=Groups Domains Extractor
-Name[pl]=Ekstraktor Domen Grup
-Comment=Finding all domains of specific group and copying it to clipboard
-Comment[pl]=Odnajdywanie wszystkich domen danej grupy i kopiowanie ich do schowka
-Exec=/usr/bin/GDE
-Terminal=false
-Type=Application
-Categories=Utility;Application;
-StartupNotify=false
-END
-
- install -Dm644 "$srcdir"/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_name-$pkgver" || exit
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ mkdir -p "$pkgdir"/usr/share/applications
+ install -Dm755 "$srcdir/$_name-$pkgver/GDE/shortcuts/share/applications/GDE.desktop" "$pkgdir"/usr/share/applications/
}