summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhawkeye1164772021-01-29 17:47:36 +0100
committerhawkeye1164772021-01-29 17:47:36 +0100
commita31ee4022a692bf47fd8e0e2f19ee1669cf09ee4 (patch)
tree29c6296638aa3a756772a634c4a2aeeb61a0aa96
downloadaur-a31ee4022a692bf47fd8e0e2f19ee1669cf09ee4.tar.gz
First
-rw-r--r--.SRCINFO23
-rw-r--r--LICENSE.txt17
-rw-r--r--PKGBUILD49
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bf14a54cd85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = groupsdomainsextractor
+ pkgdesc = Find all domains of specific group and copy it to clipboard
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/PolishFiltersTeam/ScriptsPlayground/blob/master/Readme_GDE.md
+ arch = any
+ license = MIT
+ makedepends = unzip
+ depends = python
+ depends = python-certifi
+ depends = python-urllib3
+ depends = python-beautifulsoup4
+ depends = python-tldextract
+ depends = python-pysimplegui
+ depends = python-appdirs
+ depends = python-html5lib
+ source = https://github.com/PolishFiltersTeam/ScriptsPlayground/releases/download/GDE-1.2.2/GDE.zip
+ source = LICENSE.txt
+ sha256sums = de399487adc99094dbaf00a22658befbb58b5d17ddcea8d3bc70c4e5de003363
+ sha256sums = 84c872a68ddd7b81d71673d560480dcaf0d83a7f694bb6521b2dbcebd2d2c912
+
+pkgname = groupsdomainsextractor
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..76c36e272350
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,17 @@
+MIT License
+Copyright (c) 2019 Polish Filters Team
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ec2c71d91cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: hawkeye116477 <hawkeye116477 at gmail.com>
+pkgname=groupsdomainsextractor
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="Find all domains of specific group and copy it to clipboard"
+url="https://github.com/PolishFiltersTeam/ScriptsPlayground/blob/master/Readme_GDE.md"
+license=('MIT')
+depends=('python' 'python-certifi' 'python-urllib3' 'python-beautifulsoup4' 'python-tldextract' 'python-pysimplegui' 'python-appdirs' 'python-html5lib')
+makedepends=('unzip')
+arch=('any')
+source=(
+ "https://github.com/PolishFiltersTeam/ScriptsPlayground/releases/download/GDE-$pkgver/GDE.zip"
+ "LICENSE.txt"
+)
+sha256sums=('de399487adc99094dbaf00a22658befbb58b5d17ddcea8d3bc70c4e5de003363'
+ '84c872a68ddd7b81d71673d560480dcaf0d83a7f694bb6521b2dbcebd2d2c912')
+
+prepare() {
+ mkdir -p "$srcdir"/opt/
+ unzip GDE.zip -d "$srcdir"/opt/$pkgname/
+ rm -rf "$srcdir"/opt/$pkgname/requirements.txt
+}
+
+package()
+{
+ mkdir -p "$pkgdir"/opt/$pkgname/
+ cp -R "$srcdir"/opt/* "$pkgdir"/opt/
+
+ install -Dm755 /dev/stdin "$pkgdir/usr/bin/GDE" <<END
+#!/bin/bash
+python3 /opt/$pkgname/GDE.py "\$@"
+END
+
+ install -Dm755 /dev/stdin "$pkgdir/usr/share/applications/GDE.desktop" <<END
+[Desktop Entry]
+Version=1.0
+Name=Groups Domains Extractor
+Name[pl]=Ekstraktor Domen Grup
+Comment=Finding all domains of specific group and copying it to clipboard
+Comment[pl]=Odnajdywanie wszystkich domen danej grupy i kopiowanie ich do schowka
+Exec=/usr/bin/GDE
+Terminal=false
+Type=Application
+Categories=Utility;Application;
+StartupNotify=false
+END
+
+ install -Dm644 "$srcdir"/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}