summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAUR Archive Bot2015-08-16 01:42:22 +0200
committerAUR Archive Bot2015-08-16 01:42:22 +0200
commita764fa8001aad83d219b8a3269a25c361c954067 (patch)
treed2ee2c13ff030d2c9669a6b450bd8c618baf1a7f
downloadaur-a764fa8001aad83d219b8a3269a25c361c954067.tar.gz
Initial AUR Archive commit of 'growl-for-linux'
(full history will be added later)
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD37
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..681f778ebbde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 4.2.1
+# Sat Apr 25 08:36:23 UTC 2015
+pkgbase = growl-for-linux
+ pkgdesc = Growl for Linux
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = http://mattn.github.com/growl-for-linux/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = git
+ depends = openssl
+ depends = curl
+ depends = gtk2
+ depends = sqlite3
+ depends = dbus-glib
+ depends = desktop-file-utils
+ optdepends = libnotify
+ conflicts = growl-for-linux-git
+ options = !libtool
+ source = growl-for-linux-0.8.1.tar.gz::https://github.com/mattn/growl-for-linux/archive/0.8.1.tar.gz
+ md5sums = 65b89ab4a5d7eeeb4ecc12fb26afcf32
+
+pkgname = growl-for-linux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe844aed6809
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: anekos <anekos@snca.net>
+pkgname=growl-for-linux
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Growl for Linux"
+url="http://mattn.github.com/growl-for-linux/"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('git' 'openssl' 'curl' 'gtk2' 'sqlite3' 'dbus-glib' 'desktop-file-utils')
+optdepends=('libnotify')
+makedepends=()
+conflicts=('growl-for-linux-git')
+replaces=()
+backup=()
+options=('!libtool')
+
+
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mattn/growl-for-linux/archive/${pkgver}.tar.gz")
+md5sums=('65b89ab4a5d7eeeb4ecc12fb26afcf32')
+dirname="growl-for-linux-${pkgver}"
+
+build () {
+ cd "$srcdir/$dirname"
+
+ export LDFLAGS="$LDFLAGS -lgmodule-2.0 -lgthread-2.0"
+ export LIBNOTIFY_LIBS="-lnotify"
+ ./autogen.sh
+ ./configure --prefix=/usr && make
+}
+
+package () {
+ cd "$srcdir/$dirname"
+ echo $PWD
+ make install DESTDIR="$pkgdir" prefix=/usr
+}
+
+# vim:set ts=2 sw=2 et: