summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornick black2019-11-05 02:58:57 -0500
committernick black2019-11-05 03:02:17 -0500
commit4fe2ef8d693f8683f355cb51445bb31282c81275 (patch)
treef7fb591b88fa1d175423e89d18a2e94f7778ba15
parentc8d892aeb5f1639d4a7d4fac3c262434e9bc16c0 (diff)
downloadaur-4fe2ef8d693f8683f355cb51445bb31282c81275.tar.gz
1.1.3-2: flip back on ZFS support, outcurses 0.0.5+
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b5ccb4d9d31..b089bbf11b55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = growlight
pkgdesc = Disk manipulation and system preparation tool
pkgver = 1.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://nick-black.com/dankwiki/index.php/Growlight
arch = x86_64
license = GPL3
@@ -10,7 +10,7 @@ pkgbase = growlight
makedepends = autoconf-archive
makedepends = libxslt
makedepends = autoconf
- makedepends = outcurses
+ makedepends = outcurses>=0.0.5
depends = cryptsetup
depends = libatasmart
depends = libpciaccess
@@ -23,9 +23,10 @@ pkgbase = growlight
optdepends = ntfs-3g: NTFS (Windows) manipulation
optdepends = f2fs-tools: F2FS manipulation
optdepends = hdparm: Deep ATA hardware details
- optdepends = nvme-cli: Deep NVMe hardware details
+ optdepends = nvme-cli: Deep NVMe hardware details,
+ optdepends = zfs-utils>=0.8.0: ZFS-on-Linux manipulation
source = https://github.com/dankamongmen/growlight/archive/v1.1.3.tar.gz
- sha256sums = d73da05fd0a3de8103307701fcb64d7cfc9f13375060d11fd96b5d2cbfb7aca7
+ sha256sums = 14aa5d1c7d8f5da9f611733a2082835c6f5d57a92f3c6e156e6b3819a15f2c73
pkgname = growlight
diff --git a/PKGBUILD b/PKGBUILD
index 15d8a28b1c67..80f5c2e9286e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=growlight
pkgver=1.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Disk manipulation and system preparation tool"
url="https://nick-black.com/dankwiki/index.php/Growlight"
license=('GPL3')
@@ -10,7 +10,7 @@ arch=('x86_64')
# ncurses and readline are found without our help. Don't explicitly list them.
# The same goes for device-mapper.
depends=('cryptsetup' 'libatasmart' 'libpciaccess' 'pciutils')
-makedepends=('cunit' 'docbook-xsl' 'autoconf-archive' 'libxslt' 'autoconf' 'outcurses')
+makedepends=('cunit' 'docbook-xsl' 'autoconf-archive' 'libxslt' 'autoconf' 'outcurses>=0.0.5')
optdepends=('jfsutils: JFS manipulation'
'xfsprogs: XFS manipulation'
'mdadm: Linux MDRAID manipulation'
@@ -19,13 +19,19 @@ optdepends=('jfsutils: JFS manipulation'
'ntfs-3g: NTFS (Windows) manipulation'
'f2fs-tools: F2FS manipulation'
'hdparm: Deep ATA hardware details'
- 'nvme-cli: Deep NVMe hardware details')
+ 'nvme-cli: Deep NVMe hardware details',
+ 'zfs-utils>=0.8.0: ZFS-on-Linux manipulation')
source=("https://github.com/dankamongmen/growlight/archive/v${pkgver}.tar.gz")
build() {
cd "$pkgname-$pkgver"
autoreconf -fis
- ./configure --prefix=/usr --with-ncurses
+ if pkg-config --modversion libzfs > /dev/null 2>&1 ; then
+ ./configure --prefix=/usr
+ else
+ echo "Building without ZFS support..."
+ ./configure --prefix=/usr --disable-zfs
+ fi
make
}
@@ -34,4 +40,9 @@ package() {
make DESTDIR="$pkgdir/" install
}
+check() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" check
+}
+
sha256sums=('14aa5d1c7d8f5da9f611733a2082835c6f5d57a92f3c6e156e6b3819a15f2c73')