summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornick black2021-02-16 20:04:53 -0500
committernick black2021-02-16 20:04:53 -0500
commitf4c9ea620fabeed519aa30839bc4208c18932761 (patch)
tree893c9f958182a98b944ff8824b201cae744e82f9
parent62e09bdb46c740bb291aca46bce2f67a08bcf69f (diff)
downloadaur-f4c9ea620fabeed519aa30839bc4208c18932761.tar.gz
new upstream 1.2.31, add doctest dep
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 08cf9b185338..11d3d6e2833e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = growlight
pkgdesc = Disk manipulation and system preparation tool
- pkgver = 1.2.30
+ pkgver = 1.2.31
pkgrel = 1
url = https://nick-black.com/dankwiki/index.php/Growlight
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = growlight
makedepends = cunit
makedepends = cmake
makedepends = pandoc
+ makedepends = doctest
depends = cryptsetup
depends = libatasmart
depends = libpciaccess
@@ -23,8 +24,8 @@ pkgbase = growlight
optdepends = hdparm: Deep ATA hardware details
optdepends = nvme-cli: Deep NVMe hardware details,
optdepends = zfs-utils: ZFS-on-Linux manipulation
- source = https://github.com/dankamongmen/growlight/archive/v1.2.30.tar.gz
- sha256sums = c810b0e0f3630f2d79c81801dafe67fa136c75d5f92777d57f632f757362bae7
+ source = https://github.com/dankamongmen/growlight/archive/v1.2.31.tar.gz
+ sha256sums = 25cf643d99be88d299756ccb2933868641abecbc26793f5d87cfae93a461e2d6
pkgname = growlight
diff --git a/PKGBUILD b/PKGBUILD
index ec63a20b2ab3..fa3eeb146290 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nick Black <dankamongmen@gmail.com>
pkgname=growlight
-pkgver=1.2.30
+pkgver=1.2.31
pkgrel=1
pkgdesc="Disk manipulation and system preparation tool"
url="https://nick-black.com/dankwiki/index.php/Growlight"
@@ -10,7 +10,7 @@ arch=('x86_64')
# readline is found without our help. Don't explicitly list it.
# The same goes for device-mapper.
depends=('cryptsetup' 'libatasmart' 'libpciaccess' 'pciutils' 'notcurses>=2.2.1')
-makedepends=('cunit' 'cmake' 'pandoc')
+makedepends=('cunit' 'cmake' 'pandoc' 'doctest')
optdepends=('jfsutils: JFS manipulation' 'xfsprogs: XFS manipulation'
'mdadm: Linux MDRAID manipulation'
'btrfs-progs: Btrfs manipulation'
@@ -50,4 +50,4 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha256sums=('c810b0e0f3630f2d79c81801dafe67fa136c75d5f92777d57f632f757362bae7')
+sha256sums=('25cf643d99be88d299756ccb2933868641abecbc26793f5d87cfae93a461e2d6')