summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksey Filippov2015-05-30 03:13:06 +0400
committerAleksey Filippov2015-05-30 03:13:06 +0400
commitfb28c7fe915c12f9a2849fc7b7581667bf210360 (patch)
tree0f947947dd3656698134cb4f8856800a4806eb61
parentce67edb428766a17ccb1102f824c655907fb4ff3 (diff)
downloadaur-fb28c7fe915c12f9a2849fc7b7581667bf210360.tar.gz
Updated grpc and protobuf3 packages.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a387aabbef90..ecc4d24a04fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = grpc
pkgdesc = A high performance, open source, general RPC framework that puts mobile and HTTP/2 first.
- pkgver = 0.6.0
- pkgrel = 5
+ pkgver = 0.9.0
+ pkgrel = 2
url = http://www.grpc.io/
arch = i686
arch = x86_64
license = BSD
depends = openssl
depends = protobuf3
- source = https://github.com/grpc/grpc/archive/release-0_6_0.tar.gz
- md5sums = b50254e9149723b97654186b66f64571
+ source = https://github.com/grpc/grpc/archive/release-0_9_0.tar.gz
+ md5sums = e500db71cb1f114c4a15a5d6d141df7a
pkgname = grpc
diff --git a/PKGBUILD b/PKGBUILD
index 2f862d14ec55..15f062644cb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
pkgname=grpc
-pkgver=0.6.0
+pkgver=0.9.0
_pkgver=$(echo $pkgver | tr . _)
-pkgrel=5
+pkgrel=2
pkgdesc="A high performance, open source, general RPC framework that puts mobile and HTTP/2 first."
arch=('i686' 'x86_64')
url='http://www.grpc.io/'
license=('BSD')
depends=('openssl' 'protobuf3')
source=(https://github.com/$pkgname/$pkgname/archive/release-$_pkgver.tar.gz)
-md5sums=('b50254e9149723b97654186b66f64571')
+md5sums=('e500db71cb1f114c4a15a5d6d141df7a')
build() {
cd $pkgname-release-$_pkgver
# Avoid collision with yaourt's environment variable
- find . -type f -exec sed -r 's|__FUNCTION__|__func__|g;s|c89|c99|g' -i '{}' ';'
env --unset=BUILDDIR make $MAKEFLAGS prefix=/usr
}