summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitalii Kuzhdin2025-03-07 22:59:33 +0100
committerVitalii Kuzhdin2025-03-07 22:59:33 +0100
commit31350ec53539b366a1dbe3e99ecf38f26fc0efec (patch)
tree6e6e19771bd48a4708aa11313e8ca5f69d6e3f1b
downloadaur-31350ec53539b366a1dbe3e99ecf38f26fc0efec.tar.gz
Initial build (2.26.3)
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore5
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD38
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e6c8a025967
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = grpc-gateway-bin
+ pkgdesc = gRPC to JSON proxy generator following the gRPC HTTP spec
+ pkgver = 2.26.3
+ pkgrel = 1
+ url = https://grpc-ecosystem.github.io/grpc-gateway/
+ arch = aarch64
+ arch = x86_64
+ license = BSD-3-Clause
+ depends = protobuf
+ depends = protoc-gen-go
+ depends = protoc-gen-go-grpc
+ provides = grpc-gateway
+ provides = protoc-gen-grpc-gateway
+ provides = protoc-gen-openapiv2
+ conflicts = grpc-gateway
+ source = grpc-gateway-2.26.3-README.md::https://github.com/grpc-ecosystem/grpc-gateway/raw/refs/tags/v2.26.3/README.md
+ source = grpc-gateway-2.26.3-LICENSE::https://github.com/grpc-ecosystem/grpc-gateway/raw/refs/tags/v2.26.3/LICENSE
+ sha256sums = 34032a76bdc92ab2b2c22e68cd2c57a434d8f2355cc285f2675eeb9d754d037c
+ sha256sums = a15b1d1b168954c92ff7fb1620382418f7c72f4f4d251ee791d1098ad68ab0c4
+ source_aarch64 = protoc-gen-grpc-gateway-2.26.3-aarch64::https://github.com/grpc-ecosystem/grpc-gateway/releases/download/v2.26.3/protoc-gen-grpc-gateway-v2.26.3-linux-arm64
+ source_aarch64 = protoc-gen-openapiv2-2.26.3-aarch64::https://github.com/grpc-ecosystem/grpc-gateway/releases/download/v2.26.3/protoc-gen-openapiv2-v2.26.3-linux-arm64
+ sha256sums_aarch64 = c07ecc2f0ea723b1a8e92281c3d3f37289ee0fc29fbd2219f3fdf7f974233e94
+ sha256sums_aarch64 = 488e64eb06165545e213efc1fd9e06196dc88c9e2344c4b2b0d8e7a09538bd6a
+ source_x86_64 = protoc-gen-grpc-gateway-2.26.3-x86_64::https://github.com/grpc-ecosystem/grpc-gateway/releases/download/v2.26.3/protoc-gen-grpc-gateway-v2.26.3-linux-x86_64
+ source_x86_64 = protoc-gen-openapiv2-2.26.3-x86_64::https://github.com/grpc-ecosystem/grpc-gateway/releases/download/v2.26.3/protoc-gen-openapiv2-v2.26.3-linux-x86_64
+ sha256sums_x86_64 = f7698dfa878b83d6a6387d03984afa419bed4b0c1439f1092db89034cd708318
+ sha256sums_x86_64 = a4eec19cfced95a71994c000f68b72038fba381a08266f0e9bb1931165a8aede
+
+pkgname = grpc-gateway-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..218cc907c9ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!.nvchecker.toml
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..2a567bf52d60
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[grpc-gateway-bin]
+source = "github"
+github = "grpc-ecosystem/grpc-gateway"
+use_latest_release = true
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d6417be958e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Vitalii Kuzhdin <vitaliikuzhdin@gmail.com>
+
+_name=("protoc-gen-grpc-gateway" "protoc-gen-openapiv2")
+_pkgname="grpc-gateway"
+pkgname="${_pkgname}-bin"
+pkgver=2.26.3
+pkgrel=1
+pkgdesc="gRPC to JSON proxy generator following the gRPC HTTP spec"
+arch=('aarch64' 'x86_64')
+url="https://grpc-ecosystem.github.io/grpc-gateway/"
+_url="https://github.com/grpc-ecosystem/${_pkgname}"
+license=('BSD-3-Clause')
+depends=('protobuf' 'protoc-gen-go' 'protoc-gen-go-grpc')
+provides=("${_pkgname}" "${_name[@]}")
+conflicts=("${_pkgname}")
+_pkgsrc="${_pkgname}-${pkgver}"
+source=("${_pkgsrc}-README.md::${_url}/raw/refs/tags/v${pkgver}/README.md"
+ "${_pkgsrc}-LICENSE::${_url}/raw/refs/tags/v${pkgver}/LICENSE")
+for _binary in "${_name[@]}"; do
+ source_aarch64+=("${_binary}-${pkgver}-aarch64::${_url}/releases/download/v${pkgver}/${_binary}-v${pkgver}-linux-arm64")
+ source_x86_64+=("${_binary}-${pkgver}-x86_64::${_url}/releases/download/v${pkgver}/${_binary}-v${pkgver}-linux-x86_64")
+done
+sha256sums=('34032a76bdc92ab2b2c22e68cd2c57a434d8f2355cc285f2675eeb9d754d037c'
+ 'a15b1d1b168954c92ff7fb1620382418f7c72f4f4d251ee791d1098ad68ab0c4')
+sha256sums_aarch64=('c07ecc2f0ea723b1a8e92281c3d3f37289ee0fc29fbd2219f3fdf7f974233e94'
+ '488e64eb06165545e213efc1fd9e06196dc88c9e2344c4b2b0d8e7a09538bd6a')
+sha256sums_x86_64=('f7698dfa878b83d6a6387d03984afa419bed4b0c1439f1092db89034cd708318'
+ 'a4eec19cfced95a71994c000f68b72038fba381a08266f0e9bb1931165a8aede')
+
+package() {
+ cd "${srcdir}"
+ for _binary in "${_name[@]}"; do
+ install -vDm755 "${_binary}-${pkgver}-${CARCH}" "${pkgdir}/usr/bin/${_binary}"
+ done
+
+ install -vDm644 "${_pkgsrc}-README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -vDm644 "${_pkgsrc}-LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}