summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Schäfer2017-06-12 23:04:41 +0200
committerSimon Schäfer2017-06-12 23:07:40 +0200
commitfeb87344ad9f571d10db36f9feec1589c9a63b28 (patch)
tree156ce5a9db2788ee636aeb383036353fe3fbc219
downloadaur-feb87344ad9f571d10db36f9feec1589c9a63b28.tar.gz
initial commit of grpc-git
* this one works with boringssl, instead of openssl, since grpc is currently not working with the openssl 1.0 api * it also includes all buildable plugins
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD63
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..232ca06675ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = grpc-git-boringssl
+ pkgdesc = gRPC - An RPC library and framework, using BoringSSL
+ pkgver = v1.3.5.r1003.gb2eceb167d
+ pkgrel = 1
+ url = http://www.grpc.io/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = gflags
+ makedepends = go
+ makedepends = zlib
+ makedepends = perl
+ depends = c-ares
+ depends = protobuf>=3
+ conflicts = grpc,
+ conflicts = grpc-git
+ options = !makeflags
+ source = git+https://github.com/grpc/grpc.git#branch=v1.4.x
+ md5sums = SKIP
+
+pkgname = grpc-git-boringssl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..98c1827701b9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/*
+grpc/*
+pkg/*
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf70cff7972a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Simon Schäfer <simon.schaefer@koeln.de>
+# Based on PKGBUILD by Daichi Shinozaki <dsdseg@gmail.com> but this build uses boringssl and builds all plugins
+
+pkgname=grpc-git-boringssl
+_pkgname=${pkgname/-git-boringssl/}
+pkgver=v1.3.5.r1003.gb2eceb167d
+pkgrel=1
+pkgdesc="gRPC - An RPC library and framework, using BoringSSL"
+arch=('i686' 'x86_64')
+url='http://www.grpc.io/'
+license=('BSD')
+conflicts=('grpc', 'grpc-git')
+depends=('c-ares' 'protobuf>=3')
+makedepends=('gflags' 'go' 'zlib' 'perl') # BoringSSL require Go and Perl to build
+options=(!makeflags)
+# source=('git+https://github.com/grpc/grpc.git')
+source=('git+https://github.com/grpc/grpc.git#branch=v1.4.x')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$_pkgname"
+
+ git submodule init -- third_party/boringssl
+ git submodule init -- third_party/benchmark
+ git submodule update
+
+ mkdir -p build
+}
+
+build() {
+ cd "$_pkgname/build"
+
+ cmake .. \
+ -DgRPC_BUILD_TESTS:BOOL=OFF \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" \
+ -DBORINGSSL_ROOT_DIR="$srcdir/$_pkgname"/third_party/boringssl/ \
+ -DgRPC_ZLIB_PROVIDER=package \
+ -DgRPC_GFLAGS_PROVIDER=packet \
+ -DgRPC_PROTOBUF_PROVIDER=package \
+ -DgRPC_CARES_PROVIDER=packet \
+ -D_gRPC_PROTOBUF_PROTOC_LIBRARIES=protoc \
+ -D_gRPC_PROTOBUF_PROTOC=/usr/bin/protoc \
+ -DCMAKE_C_FLAGS="-Wno-error=stringop-overflow -lprotobuf -lprotoc" \
+ -DCMAKE_CXX_FLAGS="-lprotobuf -lprotoc -lcares" # hack with the libprotobuf and libprotoc since the cmakelist does not find it correctly, and cares since this is not added by the packet searcher
+
+ make -j$(nproc)
+}
+
+package() {
+ cd "$_pkgname/build"
+
+ make install
+ install -Dm644 ../LICENSE "$pkgdir"/usr/share/licenses/$_pkgname/LICENSE
+ # cleanup protobuf stuff since this comes from the arch package
+ rm -rf "$pkgdir/usr/bin/protoc"
+ rm -rf "$pkgdir/usr/include/google"
+}