summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCédric Connes2020-10-09 17:56:22 +0200
committerCédric Connes2020-10-09 17:56:22 +0200
commita31a6ac8a6a846c1eb2529154d8b19d0aaf0934b (patch)
tree0f427fc1ab1f508999d80c010c7376a5863f6e22
downloadaur-a31a6ac8a6a846c1eb2529154d8b19d0aaf0934b.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d68e0872eb7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = grpcui
+ pkgdesc = An interactive web UI for gRPC, along the lines of postman
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/fullstorydev/grpcui
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = go
+ source = https://github.com/fullstorydev/grpcui/archive/v1.0.0.tar.gz
+ sha256sums = 2169f72d23a5e4caceee3b863220bf6a4b4a15f7d88d5bb0de909ca4299a92df
+
+pkgname = grpcui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81bd13479631
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Cédric Connes <cedric.connes@gmail.com>
+
+pkgname=grpcui
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='An interactive web UI for gRPC, along the lines of postman'
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/fullstorydev/grpcui"
+license=('MIT')
+makedepends=('go')
+source=("https://github.com/fullstorydev/grpcui/archive/v$pkgver.tar.gz")
+sha256sums=('2169f72d23a5e4caceee3b863220bf6a4b4a15f7d88d5bb0de909ca4299a92df')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ go build \
+ -buildmode=pie \
+ -trimpath \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags="-linkmode=external -X=main.version=v$pkgver" \
+ -o build ./cmd/$pkgname
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README.md
+}