summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2020-05-23 01:17:18 -0400
committerCody P Schafer2020-05-23 01:17:18 -0400
commit7e21016e7674d56920b1ef3c202c91e76cbdd2c2 (patch)
tree09922eb3e90bdcf178ccb65f7a41b7308afb16f7
parenta7c3a60171457bbc61dcf9263c35358d5495e2e7 (diff)
downloadaur-7e21016e7674d56920b1ef3c202c91e76cbdd2c2.tar.gz
avoid build issue when `go build` tries to use `-o` as filename instead of dir
-rw-r--r--PKGBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a9a6b04a50d..081dadee0e8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,6 +21,7 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ mkdir -p build
go build -o build ./cmd/...
}