summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody Schafer2020-05-18 19:36:08 -0400
committerCody Schafer2020-05-18 19:36:08 -0400
commitf0fc05b89e823c1aa4cca85df4304206a6456bbc (patch)
tree6467baec36b34c6cef3f4ea73c33b0dad2551337
parentfb6bd01778c9dd73363b514ace5e5938331acd3c (diff)
downloadaur-f0fc05b89e823c1aa4cca85df4304206a6456bbc.tar.gz
update for new go packaging
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 574ef5f3ee8e..4d99fc83b090 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=grpcurl
pkgver=1.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="Like cURL, but for gRPC: Command-line tool for interacting with gRPC servers"
arch=(x86_64)
url="https://github.com/fullstorydev/grpcurl"
license=('MIT')
-makedepends=('go-pie')
+makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/fullstorydev/grpcurl/archive/v$pkgver.tar.gz")
md5sums=('2be962886db190fd11b5f4492ac979d9')
# really, `grpcurl-bin` should be conflicting with us instead of the oposite
@@ -17,7 +17,11 @@ build() {
cd "$pkgname-$pkgver"
go build \
-trimpath \
+ -mod=readonly \
+ -modcacherw \
+ -buildmode=pie \
-ldflags "-extldflags ${LDFLAGS}" \
+ -o build \
./cmd/grpcurl
}