summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody Schafer2020-04-14 14:39:39 -0400
committerCody Schafer2020-04-14 14:39:39 -0400
commitfb6bd01778c9dd73363b514ace5e5938331acd3c (patch)
tree02307d1b778aa39e6f856c96fda3adbc758dc331
downloadaur-fb6bd01778c9dd73363b514ace5e5938331acd3c.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4648e014a75c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = grpcurl
+ pkgdesc = Like cURL, but for gRPC: Command-line tool for interacting with gRPC servers
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://github.com/fullstorydev/grpcurl
+ arch = x86_64
+ license = MIT
+ makedepends = go-pie
+ conflicts = grpcurl-bin
+ source = grpcurl-1.5.1.tar.gz::https://github.com/fullstorydev/grpcurl/archive/v1.5.1.tar.gz
+ md5sums = 2be962886db190fd11b5f4492ac979d9
+
+pkgname = grpcurl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d60fda9ca35
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar.*
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..574ef5f3ee8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Cody Schafer <dev@codyps.com>
+
+pkgname=grpcurl
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="Like cURL, but for gRPC: Command-line tool for interacting with gRPC servers"
+arch=(x86_64)
+url="https://github.com/fullstorydev/grpcurl"
+license=('MIT')
+makedepends=('go-pie')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fullstorydev/grpcurl/archive/v$pkgver.tar.gz")
+md5sums=('2be962886db190fd11b5f4492ac979d9')
+# really, `grpcurl-bin` should be conflicting with us instead of the oposite
+conflicts=('grpcurl-bin')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go build \
+ -trimpath \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ ./cmd/grpcurl
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 grpcurl "${pkgdir}/usr/bin/grpcurl"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}