summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn A. Leuenhagen2021-03-07 16:40:48 -0500
committerJohn A. Leuenhagen2021-03-07 16:40:48 -0500
commit44b5c705010216d5368b8b327ee399aba48b9c04 (patch)
tree698c3ce14219c53cc8d1e865eb533fd2707673b7
parent3460e470c230c1b658415268ba90880e38c72195 (diff)
downloadaur-44b5c705010216d5368b8b327ee399aba48b9c04.tar.gz
Update to v4.4.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2f730d86117..9acc866053c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = grrlib
pkgdesc = A helper library for Nintendo Gamecube/Wii homebrew developers
- pkgver = 4.3.2
- pkgrel = 2
+ pkgver = 4.4.1
+ pkgrel = 1
url = http://grrlib.santo.fr/
arch = any
license = MIT
- makedepends = devkitppc
+ makedepends = devkitPPC
depends = libfat-ogc
options = !strip
options = staticlibs
- source = https://github.com/GRRLIB/GRRLIB/archive/4.3.2.tar.gz
- source = https://github.com/GRRLIB/GRRLIB/releases/download/4.3.2/HTML-documentation.zip
- sha256sums = 198e8d4f06cb1e6b7328569ca4ccb7e238e18cb2fc90225fd7e28b7583d16f49
- sha256sums = 44a2df2136825da162d047bfeec130e96825afd292d7eb4c02b15505611a7ded
+ source = https://github.com/GRRLIB/GRRLIB/archive/v4.4.1.tar.gz
+ source = https://github.com/GRRLIB/GRRLIB/releases/download/v4.4.1/PDF-documentation.pdf
+ sha256sums = cc5e1453fb088a49f04f49d6e27901f63a22fe4e26bf6972b57d00b291870a7a
+ sha256sums = db015694ff53dfde0f8666165dd8d5e743ea8ef80d566b25f7cee197b467e7d2
pkgname = grrlib
diff --git a/PKGBUILD b/PKGBUILD
index 32c028ccd6e2..29f566b0f173 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
# Contributor: Gerardo Marset <gammer1994@gmail.com>
pkgname=grrlib
-pkgver=4.3.2
-pkgrel=2
+pkgver=4.4.1
+pkgrel=1
pkgdesc="A helper library for Nintendo Gamecube/Wii homebrew developers"
arch=('any')
url="http://grrlib.santo.fr/"
license=('MIT')
depends=("libfat-ogc")
-makedepends=("devkitppc")
-source=("https://github.com/GRRLIB/GRRLIB/archive/$pkgver.tar.gz"
- "https://github.com/GRRLIB/GRRLIB/releases/download/$pkgver/HTML-documentation.zip")
-sha256sums=('198e8d4f06cb1e6b7328569ca4ccb7e238e18cb2fc90225fd7e28b7583d16f49'
- '44a2df2136825da162d047bfeec130e96825afd292d7eb4c02b15505611a7ded')
+makedepends=("devkitPPC")
+source=("https://github.com/GRRLIB/GRRLIB/archive/v$pkgver.tar.gz"
+ "https://github.com/GRRLIB/GRRLIB/releases/download/v$pkgver/PDF-documentation.pdf")
+sha256sums=('cc5e1453fb088a49f04f49d6e27901f63a22fe4e26bf6972b57d00b291870a7a'
+ 'db015694ff53dfde0f8666165dd8d5e743ea8ef80d566b25f7cee197b467e7d2')
options=(!strip staticlibs)
build() {
# set environment
- source /etc/profile.d/devkitppc.sh
+ source /etc/profile.d/devkit-env.sh
unset CFLAGS
make -C GRRLIB-$pkgver/GRRLIB
@@ -29,12 +29,11 @@ package() {
DEVKITPRO="$pkgdir/$DEVKITPRO" make -C GRRLIB install
# license
- install -Dm0644 LICENCE.TXT "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm0644 LICENCE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
# examples
install -d "$pkgdir"/usr/share/$pkgname
cp -rup examples "$pkgdir"/usr/share/$pkgname
# doc
install -d "$pkgdir"/usr/share/doc/$pkgname/doxygen
- install -m0644 README.html grrlib_logo.png "$pkgdir"/usr/share/doc/$pkgname
- cp -rup ../doc/* "$pkgdir"/usr/share/doc/$pkgname/doxygen
+ install -m0644 README.md docs/* ../PDF-documentation.pdf "$pkgdir"/usr/share/doc/$pkgname
}