summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2022-12-10 12:47:16 -0800
committerLlewelyn Trahaearn2022-12-10 12:47:16 -0800
commit8716872f4dfe514950e7104d95d641f321308b5d (patch)
treecd3e259a2a73b07b23be522a4cd2da75a985361d
parent7dd997a25775a5fd6f6f57597a55ec01a1216d63 (diff)
downloadaur-8716872f4dfe514950e7104d95d641f321308b5d.tar.gz
Fix incompatible license issue when building in clean chroot.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
-rw-r--r--grub-git.install18
-rw-r--r--grub.default2
4 files changed, 29 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a85c0c1cf6f..e245a252a8ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = grub-git
pkgdesc = GNU GRand Unified Bootloader (2)
- pkgver = 2.06.r297.g0c6c1aff2
+ pkgver = 2.06.r403.g7259d55ff
pkgrel = 1
url = https://www.gnu.org/software/grub/
install = grub-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 26926ae55ff5..261f315bec98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ _build_platforms="i386-pc ${_target_arch}-efi"
[[ "${_grub_emu_build}" == "1" ]] && _build_platforms+=" ${_target_arch}-emu"
pkgname="grub-git"
-pkgver=2.06.r297.g0c6c1aff2
+pkgver=2.06.r403.g7259d55ff
pkgrel=1
pkgdesc="GNU GRand Unified Bootloader (2)"
arch=('x86_64' 'i686')
@@ -59,6 +59,8 @@ sha256sums=('SKIP'
prepare() {
cd grub
+ export GRUB_CONTRIB="$srcdir"/grub-extras
+ export GNULIB_SRCDIR="$srcdir"/gnulib
# Patch to enable GRUB_COLOR_* variables in grub-mkconfig.
# Based on http://lists.gnu.org/archive/html/grub-devel/2012-02/msg00021.html
@@ -79,9 +81,14 @@ prepare() {
# Pull in latest language files
./linguas.sh
+ # Make translations reproducible.
+ sed -i '1i /^PO-Revision-Date:/ d' po/*.sed
+
# Remove lua module from grub-extras as it is incompatible with changes to grub_file_open
# http://git.savannah.gnu.org/cgit/grub.git/commit/?id=ca0a4f689a02c2c5a5e385f874aaaa38e151564e
rm -rf "$srcdir"/grub-extras/lua
+
+ ./bootstrap
}
pkgver() {
@@ -94,14 +101,14 @@ build() {
export GRUB_CONTRIB="$srcdir"/grub-extras
export GNULIB_SRCDIR="$srcdir"/gnulib
- # Undefined references to _GLOBAL_OFFSET_TABLE_
- CFLAGS=${CFLAGS/-fno-plt}
-
- ./bootstrap
-
for _arch in $_build_platforms; do
mkdir "$srcdir"/grub/build_"$_arch"
cd "$srcdir"/grub/build_"$_arch"
+ unset CFLAGS
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset MAKEFLAGS
../configure PACKAGE_VERSION="${pkgver}-${pkgrel}" \
--with-platform="${_arch##*-}" \
diff --git a/grub-git.install b/grub-git.install
index c13ef99c77c5..503d4e7cd374 100644
--- a/grub-git.install
+++ b/grub-git.install
@@ -6,12 +6,22 @@ post_upgrade() {
if [ ! -f /boot/grub/grub.cfg -a -f /boot/grub/grub.cfg.pacsave ]; then
mv /boot/grub/grub.cfg.pacsave /boot/grub/grub.cfg
fi
+
+ # Give a hint to update installation and configuration one after another.
+ cat <<EOM
+:: To use the new features provided in this GRUB update, it is recommended
+ to install it to the MBR or UEFI. Due to potential configuration
+ incompatibilities, it is advised to run both, installation and generation
+ of configuration:
+ \$ grub-install ...
+ \$ grub-mkconfig -o /boot/grub/grub.cfg
+EOM
}
post_install() {
- cat << 'EOM'
-Generate your bootloader configuration with:
- grub-mkconfig -o /boot/grub/grub.cfg
+ cat <<EOM
+:: Install your bootloader and generate configuration with:
+ \$ grub-install ...
+ \$ grub-mkconfig -o /boot/grub/grub.cfg
EOM
}
-
diff --git a/grub.default b/grub.default
index ba1076eff4c9..5af66e3ca829 100644
--- a/grub.default
+++ b/grub.default
@@ -24,7 +24,7 @@ GRUB_TERMINAL_INPUT=console
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
-# you can see them in real GRUB with the command `vbeinfo'
+# you can see them in real GRUB with the command `videoinfo'
GRUB_GFXMODE=auto
# Uncomment to allow the kernel use the same resolution used by grub