summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 02:30:02 -0300
committerHugo Osvaldo Barrera2015-06-09 02:30:54 -0300
commit8d54730381ea3fa1da5aa99920ff7c76e3b6ae47 (patch)
tree18b0b1f9d0cf7aead474096f76633df687985830
downloadaur-grub-holdshift.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--grub-holdshift.install9
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bf1bb30820f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = grub-holdshift
+ pkgdesc = Script to hide GRUB unless shift is held down.
+ pkgver = 1.2
+ pkgrel = 2
+ url = https://github.com/hobarrera/grub-holdshift
+ install = grub-holdshift.install
+ arch = any
+ license = GPL
+ depends = grub
+ source = https://github.com/hobarrera/grub-holdshift/archive/v1.2.zip
+ md5sums = ee5422713548aa927322ba18f97b8798
+
+pkgname = grub-holdshift
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dce17276cdab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=grub-holdshift
+pkgver=1.2
+pkgrel=2
+pkgdesc="Script to hide GRUB unless shift is held down."
+arch=("any")
+license=('GPL')
+depends=("grub")
+install=$pkgname.install
+source=(https://github.com/hobarrera/${pkgname}/archive/v${pkgver}.zip)
+md5sums=('ee5422713548aa927322ba18f97b8798')
+url="https://github.com/hobarrera/grub-holdshift"
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm 755 31_hold_shift "$pkgdir/etc/grub.d/31_hold_shift"
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/${pkgname}/README.md"
+}
diff --git a/grub-holdshift.install b/grub-holdshift.install
new file mode 100644
index 000000000000..b8e86ab70208
--- /dev/null
+++ b/grub-holdshift.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo Remember to run grub-mkconfig -o /boot/grub/grub.cfg
+ echo This won\'t be automated to avoid overwriting manutally-edited
+ echo grub.cfg files.
+}
+
+post_upgrade() {
+ post_install
+}