summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2021-05-27 09:42:10 +0200
committerWilken 'Akiko' Gottwalt2021-05-27 09:42:10 +0200
commit7b49ee86b83815bf85f46e1e2c43404102e6f1ad (patch)
treec0969497071c66f1ce9a39b3ac7a81013bfbb3c5
parent79b08b2af3a551bcc32dd469ef8b50666c581c14 (diff)
downloadaur-7b49ee86b83815bf85f46e1e2c43404102e6f1ad.tar.gz
updated the objcopy-absolute patch to tackle bloat issue
Changed the objcopy process to omit complete note and comment sections which removes nearly all bloat. Some of the stage2 files are still some bytes bigger then usual, which could be caused by different optimizations from newer binutils and gcc versions.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--objcopy-absolute.patch4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f93f20e422f..0b850c007105 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = grub-legacy
pkgdesc = A GNU multiboot boot loader
pkgver = 0.97
- pkgrel = 26
+ pkgrel = 27
url = http://www.gnu.org/software/grub/
arch = i686
arch = x86_64
@@ -80,7 +80,7 @@ pkgbase = grub-legacy
sha1sums = 6a880733ad84ffebeef05515ebdf1ea451a4d054
sha1sums = 02f13de04b932093d07f9a52adf20df7f0468654
sha1sums = 8f6f13c0f752e20e690337488a178286ef1c381d
- sha1sums = 930e057794b0991557e769bc5e16f242972a70c5
+ sha1sums = 07558de2935f4eefec243a6966095b68aa3b6e70
sha1sums = 610243204b776901a9696ab65c0729ec8fdb84d1
sha1sums = c5aab6d3a5269054fc2e7f110ddc180d5595604d
sha1sums = 721bb91d381ee3e51c2e2af0b4cfa004032e15b1
diff --git a/PKGBUILD b/PKGBUILD
index 04c6626b8dc4..0449dc612de6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=grub-legacy
_srcname=grub
pkgver=0.97
-pkgrel=26
+pkgrel=27
pkgdesc="A GNU multiboot boot loader"
arch=('i686' 'x86_64')
license=('GPL')
@@ -80,7 +80,7 @@ sha1sums=('2580626c4579bd99336d3af4482c346c95dac4fb'
'6a880733ad84ffebeef05515ebdf1ea451a4d054'
'02f13de04b932093d07f9a52adf20df7f0468654'
'8f6f13c0f752e20e690337488a178286ef1c381d'
- '930e057794b0991557e769bc5e16f242972a70c5'
+ '07558de2935f4eefec243a6966095b68aa3b6e70'
'610243204b776901a9696ab65c0729ec8fdb84d1'
'c5aab6d3a5269054fc2e7f110ddc180d5595604d'
'721bb91d381ee3e51c2e2af0b4cfa004032e15b1'
diff --git a/objcopy-absolute.patch b/objcopy-absolute.patch
index 3619836047c4..3f8d2fbaf5b0 100644
--- a/objcopy-absolute.patch
+++ b/objcopy-absolute.patch
@@ -29,7 +29,7 @@ Index: b/stage1/Makefile.am
SUFFIXES = .exec
.exec:
- $(OBJCOPY) -O binary $< $@
-+ $(OBJCOPY) -O binary -R .note -R .comment -R .note.gnu.build-id $< $@
++ $(OBJCOPY) -O binary -R .note* -R .comment* $< $@
Index: b/stage2/Makefile.am
===================================================================
--- a/stage2/Makefile.am
@@ -39,4 +39,4 @@ Index: b/stage2/Makefile.am
SUFFIXES = .exec
.exec:
- $(OBJCOPY) -O binary $< $@
-+ $(OBJCOPY) -O binary -R .note -R .comment -R .note.gnu.build-id $< $@
++ $(OBJCOPY) -O binary -R .note* -R .comment* $< $@