summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreworm2018-08-25 11:48:20 +0000
committersvntogit2018-08-25 11:48:20 +0000
commit868eddb15cdedfde98b58bb0a60fc3b81dfc80bd (patch)
tree6e9ffe69b20af77ea6441a4a76ea2db01d5bd136
parent169e14373ca32d3bd47d1268416c492a22b12443 (diff)
downloadaur-868eddb15cdedfde98b58bb0a60fc3b81dfc80bd.tar.gz
fix build with binutils 2.31
git-svn-id: file:///srv/repos/svn-packages/svn@333005 eb2447ed-0c53-47e4-bac8-5bc4a241df78
-rw-r--r--.SRCINFO2
-rw-r--r--0010-relocation.patch65
-rw-r--r--PKGBUILD7
3 files changed, 73 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99772bcaf9b6..ffea23e9bfdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -59,6 +59,7 @@ pkgbase = grub
source = 0007-grub-mkconfig_10_linux_Support_multiple_early_initrd_images.patch
source = 0008-Fix-packed-not-aligned-error-on-GCC-8.patch
source = 0009-xfs-Accept-filesystem-with-sparse-inodes.patch
+ source = 0010-relocation.patch
source = grub.default
source = grub.cfg
validpgpkeys = E53D497F3FA42AD8C9B4D1E835A93B74E82E4209
@@ -75,6 +76,7 @@ pkgbase = grub
sha256sums = e43566c4fe3b1b87e677167323d4716b82ac0810410a9d8dc7fbf415c8db2b8a
sha256sums = e84b8de569c7e6b73263758c35cf95c6516fde85d4ed451991427864f6a4e5a8
sha256sums = fcd5a626d4af33665d041ce42df813f1f198d8230ea186481b155a5b676f3b87
+ sha256sums = 51562fa1016c54567dbf42a86c0cfc902372ab579bbee17879a81aff09b76b99
sha256sums = 74e5dd2090a153c10a7b9599b73bb09e70fddc6a019dd41641b0f10b9d773d82
sha256sums = c5e4f3836130c6885e9273c21f057263eba53f4b7c0e2f111f6e5f2e487a47ad
diff --git a/0010-relocation.patch b/0010-relocation.patch
new file mode 100644
index 000000000000..1aeae68493f7
--- /dev/null
+++ b/0010-relocation.patch
@@ -0,0 +1,65 @@
+commit 842c390469e2c2e10b5aa36700324cd3bde25875
+Author: H.J. Lu <hjl.tools@gmail.com>
+Date: Sat Feb 17 06:47:28 2018 -0800
+
+ x86-64: Treat R_X86_64_PLT32 as R_X86_64_PC32
+
+ Starting from binutils commit bd7ab16b4537788ad53521c45469a1bdae84ad4a:
+
+ https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=bd7ab16b4537788ad53521c45469a1bdae84ad4a
+
+ x86-64 assembler generates R_X86_64_PLT32, instead of R_X86_64_PC32, for
+ 32-bit PC-relative branches. Grub2 should treat R_X86_64_PLT32 as
+ R_X86_64_PC32.
+
+ Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
+ Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
+
+diff --git a/grub-core/efiemu/i386/loadcore64.c b/grub-core/efiemu/i386/loadcore64.c
+index e49d0b6ff..18facf47f 100644
+--- a/grub-core/efiemu/i386/loadcore64.c
++++ b/grub-core/efiemu/i386/loadcore64.c
+@@ -98,6 +98,7 @@ grub_arch_efiemu_relocate_symbols64 (grub_efiemu_segment_t segs,
+ break;
+
+ case R_X86_64_PC32:
++ case R_X86_64_PLT32:
+ err = grub_efiemu_write_value (addr,
+ *addr32 + rel->r_addend
+ + sym.off
+diff --git a/grub-core/kern/x86_64/dl.c b/grub-core/kern/x86_64/dl.c
+index 440690673..3a73e6e6c 100644
+--- a/grub-core/kern/x86_64/dl.c
++++ b/grub-core/kern/x86_64/dl.c
+@@ -70,6 +70,7 @@ grub_arch_dl_relocate_symbols (grub_dl_t mod, void *ehdr,
+ break;
+
+ case R_X86_64_PC32:
++ case R_X86_64_PLT32:
+ {
+ grub_int64_t value;
+ value = ((grub_int32_t) *addr32) + rel->r_addend + sym->st_value -
+diff --git a/util/grub-mkimagexx.c b/util/grub-mkimagexx.c
+index a2bb05439..39d7efb91 100644
+--- a/util/grub-mkimagexx.c
++++ b/util/grub-mkimagexx.c
+@@ -841,6 +841,7 @@ SUFFIX (relocate_addresses) (Elf_Ehdr *e, Elf_Shdr *sections,
+ break;
+
+ case R_X86_64_PC32:
++ case R_X86_64_PLT32:
+ {
+ grub_uint32_t *t32 = (grub_uint32_t *) target;
+ *t32 = grub_host_to_target64 (grub_target_to_host32 (*t32)
+diff --git a/util/grub-module-verifier.c b/util/grub-module-verifier.c
+index 9179285a5..a79271f66 100644
+--- a/util/grub-module-verifier.c
++++ b/util/grub-module-verifier.c
+@@ -19,6 +19,7 @@ struct grub_module_verifier_arch archs[] = {
+ -1
+ }, (int[]){
+ R_X86_64_PC32,
++ R_X86_64_PLT32,
+ -1
+ }
+ },
diff --git a/PKGBUILD b/PKGBUILD
index 9674fa492ef9..d17f4a5690af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -67,6 +67,7 @@ source=("https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz"{,.sig}
'0007-grub-mkconfig_10_linux_Support_multiple_early_initrd_images.patch'
'0008-Fix-packed-not-aligned-error-on-GCC-8.patch'
'0009-xfs-Accept-filesystem-with-sparse-inodes.patch'
+ '0010-relocation.patch'
'grub.default'
'grub.cfg')
@@ -82,6 +83,7 @@ sha256sums=('810b3798d316394f94096ec2797909dbf23c858e48f7b3830826b8daa06b7b0f'
'e43566c4fe3b1b87e677167323d4716b82ac0810410a9d8dc7fbf415c8db2b8a'
'e84b8de569c7e6b73263758c35cf95c6516fde85d4ed451991427864f6a4e5a8'
'fcd5a626d4af33665d041ce42df813f1f198d8230ea186481b155a5b676f3b87'
+ '51562fa1016c54567dbf42a86c0cfc902372ab579bbee17879a81aff09b76b99'
'74e5dd2090a153c10a7b9599b73bb09e70fddc6a019dd41641b0f10b9d773d82'
'c5e4f3836130c6885e9273c21f057263eba53f4b7c0e2f111f6e5f2e487a47ad')
@@ -130,9 +132,12 @@ prepare() {
msg "Patch to fix packed-not-aligned error on GCC 8"
patch -Np1 -i "${srcdir}/0008-Fix-packed-not-aligned-error-on-GCC-8.patch"
- msg "xfs: Accept filesystem with sparse inodes"
+ msg "Patch xfs: Accept filesystem with sparse inodes"
patch -Np1 -i "${srcdir}/0009-xfs-Accept-filesystem-with-sparse-inodes.patch"
+ msg "Patch x86-64: Treat R_X86_64_PLT32 as R_X86_64_PC32"
+ patch -Np1 -i "${srcdir}/0010-relocation.patch"
+
msg "Fix DejaVuSans.ttf location so that grub-mkfont can create *.pf2 files for starfield theme"
sed 's|/usr/share/fonts/dejavu|/usr/share/fonts/dejavu /usr/share/fonts/TTF|g' -i "configure.ac"