summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 09:15:13 -0600
committerMark Wagie2022-04-15 09:15:13 -0600
commit91aca8d30afd35fa9911d92b5c6c252b70f6e3d4 (patch)
treea22c8e1bf0be255e828df8ff5e905e593f295440
parentbaa5ab1eeb41b4b8d91d68d5667a6edc0eb2e4b2 (diff)
downloadaur-91aca8d30afd35fa9911d92b5c6c252b70f6e3d4.tar.gz
standards based build
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index daa21e507e73..761ec9788de7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = grub-reboot-picker
pkgdesc = Tray application to reboot into different OSes or UEFI/BIOS
pkgver = 0.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mendhak/grub-reboot-picker
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-gobject
depends = python-cairo
depends = libappindicator-gtk3
diff --git a/PKGBUILD b/PKGBUILD
index e40b1ad2df8f..30f97846b308 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=grub-reboot-picker
pkgver=0.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Tray application to reboot into different OSes or UEFI/BIOS"
arch=('any')
url="https://github.com/mendhak/grub-reboot-picker"
license=('MIT')
depends=('python-gobject' 'python-cairo' 'libappindicator-gtk3' 'grub' 'polkit')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
'setup.patch')
sha256sums=('ae85de0b9dfd9648598a380b7db733d6de6562529776e4e2bfbb7b3d9b80c3fe'
@@ -34,12 +34,12 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname"
}