summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-09 18:12:30 +0300
committerDimitris Kiziridis2020-07-09 18:12:30 +0300
commitc67892102e3e4fc9087ddaf7f3c51242d8af72ae (patch)
tree312dd7bed8c41f166f839fa4a8f2af318bc39a07
downloadaur-c67892102e3e4fc9087ddaf7f3c51242d8af72ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..557b8df6ac22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = grub-theme-poly-light-git
+ pkgdesc = Simple light GRUB theme
+ pkgver = r39.8f82f98
+ pkgrel = 1
+ url = https://www.pling.com/p/1176413
+ arch = any
+ license = MIT
+ makedepends = git
+ optdepends = grub-customizer: GUI tool to configure GRUB
+ source = poly-light::git+https://github.com/shvchk/poly-light
+ sha256sums = SKIP
+
+pkgname = grub-theme-poly-light-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cf82c416042
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=grub-theme-poly-light-git
+pkgver=r39.8f82f98
+pkgrel=1
+pkgdesc='Simple light GRUB theme'
+arch=('any')
+url='https://www.pling.com/p/1176413'
+license=('MIT')
+optdepends=('grub-customizer: GUI tool to configure GRUB')
+makedepends=('git')
+source=("poly-light::git+https://github.com/shvchk/poly-light")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd poly-light
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/share/grub/themes/
+ install -Dm644 poly-light/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cp -r --no-preserve=ownership poly-light "${pkgdir}"/usr/share/grub/themes/
+ rm -rf "${pkgdir}"/usr/share/grub/themes/poly-light/.git
+ rm "${pkgdir}"/usr/share/grub/themes/poly-light/LICENSE
+ rm "${pkgdir}"/usr/share/grub/themes/poly-light/README.md
+ rm "${pkgdir}"/usr/share/grub/themes/poly-light/install.sh
+} \ No newline at end of file