summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Dubois2019-02-12 06:53:28 +0100
committerErik Dubois2019-02-12 06:53:28 +0100
commit1a60d76215a1c96d76beda7f0d86f2cf85e4ae2e (patch)
treec208c5f0ffac605b25abd7a9135b2cdc9724bb92
downloadaur-1a60d76215a1c96d76beda7f0d86f2cf85e4ae2e.tar.gz
creation of new package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rwxr-xr-xgit.sh9
-rw-r--r--grub-theme-slaze-git.install16
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed13e36d76fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Feb 12 05:53:20 UTC 2019
+pkgbase = grub-theme-slaze-git
+ pkgdesc = slaze grub2 theme
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/vinceliuice/grub2-themes
+ install = grub-theme-slaze-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = grub
+ optdepends = grub-customizer
+ source = git://github.com/vinceliuice/grub2-themes
+ md5sums = SKIP
+
+pkgname = grub-theme-slaze-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80c5beed6cf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: erik dubois <erik.dubois@gmail.com>
+
+pkgname=grub-theme-slaze-git
+pkgver=1.1
+pkgrel=1
+pkgdesc='slaze grub2 theme'
+arch=(any)
+url='https://github.com/vinceliuice/grub2-themes'
+license=('GPL')
+depends=('grub')
+optdepends=('grub-customizer')
+makedepends=('git')
+conflicts=()
+install=${pkgname}.install
+source=('git://github.com/vinceliuice/grub2-themes')
+md5sums=('SKIP')
+package() {
+ install -dm755 $pkgdir/boot/grub/themes/
+ cd grub2-themes/grub-theme-slaze
+ cp -r Slaze $pkgdir/boot/grub/themes/
+
+ echo '======='
+ echo -e 'You should:\n1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/StylishDark/theme.txt"\e[0m'
+ echo -e '\e[0m \n2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m'
+ echo '----------'
+ echo -e 'also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub'
+ echo '======='
+}
diff --git a/git.sh b/git.sh
new file mode 100755
index 000000000000..de402d198f40
--- /dev/null
+++ b/git.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+mksrcinfo
+git add --all .
+echo "####################################"
+echo "Write your commit comment!"
+echo "####################################"
+read input
+git commit -m "$input"
+git push -u origin master
diff --git a/grub-theme-slaze-git.install b/grub-theme-slaze-git.install
new file mode 100644
index 000000000000..5f6a0abdb253
--- /dev/null
+++ b/grub-theme-slaze-git.install
@@ -0,0 +1,16 @@
+read -r -d '' msg << TIPS
+====================================\n
+You should:\n
+1. edit\e[36m /etc/default/grub \e[0m,add (or modify) the line \n \e[1m GRUB_THEME="/boot/grub/themes/StylishDark/theme.txt"\e[0m\e[0m \n
+2. execute \n \e[1m sudo grub-mkconfig -o /boot/grub/grub.cfg \e[0m after installation.\e[0m
+\n------------------------------------\n
+also you can use a gui app -- \e[1m grub-customizer \e[0m for changing grub\n
+====================================
+TIPS
+post_install(){
+ echo -e $msg
+}
+
+post_upgrade(){
+ echo -e $msg
+}